summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
commit6bf575618cf9022e99cbfcc64036fd9db79a749c (patch)
treef692d02fb905cd3d5bab465b790da48fb2de546b /dev-python/h5py
parent5944ce177026c93b7dab690db9d970567ddbf75f (diff)
gentoo auto-resync : 05:12:2023 - 17:02:58
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.10.0-r1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 22126a7b208b..f6d550668481 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,3 +1,5 @@
+DIST h5py-3.10.0-cython3.patch.xz 3868 BLAKE2B 3c0d952bdca5307ebf0bf878c26b94d0593bb89ac538a51017fb94e1e488bffc1583dcf4e713005b87d1b5e20d7b73043b24d65404faf60fb69515e598ca2133 SHA512 a0a0e3d1a9bccad1c89aa7efe3ba1e080eb70cae1f42f8de1021c212817970eaaa7070131e8e39859eea3c18d6c1243a17e7f53f2179f34ff6c406b315bab8fa
DIST h5py-3.10.0.tar.gz 403716 BLAKE2B a8e4351a15aee5fe9d23f9c5f9b6ff44e688a391ba17e27338675bde60415c73e3cd97a4a0c05490df849f649d626450d3dbecc9ae6ea3d24d784a0a4aaa1850 SHA512 840d7f2b9b9d5e22e8edae21c84884abec64acdd6c36437a4921ce9dc1b343c55f66f72b699146d71fe55688f6f948787b62335a24906288e9565b2b19b24b01
+EBUILD h5py-3.10.0-r1.ebuild 1431 BLAKE2B 6b8ffbb3bbd097e6e5492904c7c3f80226d813a35a049a3a3891d5b95cb55dd5f246d37617f6f03f32116ab31720c057442fbb7b8d7d7bd929caaf1f81c2ad76 SHA512 63739840043eb9ca8c5e4b8df071360465cf44bf144405c31bbb32abab8971e96899fe1d2c0b4b89a694e582c0de5521cf992640481e60038d937bb4ec47963d
EBUILD h5py-3.10.0.ebuild 1489 BLAKE2B 3590f05ab032240df42a54ee39c6ee5edf1632a6f3c659bfe4db27a3edcf8d5ef9d64e52860318498b34cd6c7be8a382e6ddc047305e61dd317b63bcfe6d7b95 SHA512 0cbd679e6d3aaad32f7cda5d958f0be2da85cfaa69862cc3bcda3b13e111fdbc1b78807be6e5dbdf22e794bf5bed31df355d865cafb618935e3a58573b417488
MISC metadata.xml 1069 BLAKE2B 0f3ef8e7af7f4bb493824427a238588c019c04c28fe8a4b9c0b9af1c986158eb3dae3b7d7937713cc4c87374ef80686603ccdbae2baff5b1150d814ab108d973 SHA512 47a6074e383cc922234ebb9f67aaa5863421eaeb2003444587bb8499b3bf845da93ac8d8d267717bea01300691df10f67c9389248fbe228afe07c17fba3a64f3
diff --git a/dev-python/h5py/h5py-3.10.0-r1.ebuild b/dev-python/h5py/h5py-3.10.0-r1.ebuild
new file mode 100644
index 000000000000..88aeec5dd302
--- /dev/null
+++ b/dev-python/h5py/h5py-3.10.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-3.10.0-cython3.patch.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ >=sci-libs/hdf5-1.10.4:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/numpy-1.17.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ >=dev-python/cython-0.29.31[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-3.10.0-cython3.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}