summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
commit6405cba4bf18141460bc9fcb8f5580532d4b46f8 (patch)
tree377baa366741990f54b18ea82f5566c48295f4e0 /dev-python/h5py
parentabc3bfc07d931f667a0f50cf607f1c8a49af879f (diff)
gentoo auto-resync : 28:09:2024 - 01:25:57
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.12.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 94568f873e27..dc364f97972d 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,4 +1,6 @@
DIST h5py-3.10.0-cython3.patch.xz 3868 BLAKE2B 3c0d952bdca5307ebf0bf878c26b94d0593bb89ac538a51017fb94e1e488bffc1583dcf4e713005b87d1b5e20d7b73043b24d65404faf60fb69515e598ca2133 SHA512 a0a0e3d1a9bccad1c89aa7efe3ba1e080eb70cae1f42f8de1021c212817970eaaa7070131e8e39859eea3c18d6c1243a17e7f53f2179f34ff6c406b315bab8fa
DIST h5py-3.11.0.tar.gz 406519 BLAKE2B a5568c96290eee1f6da965174b6fa398f94e2e1825ec4ec50efd856b37ccf2bf634cfeb32101c7c53712fe9c68b0617774e9339a3f0d9373d3df24e6763a20cf SHA512 05d99093d5e7c280779b4167bd3594488dfc348b800da95c2275ddc8d77b4208fd1353942bf8863c4859d0208e8aa8bf84e628b3c5942eb947ecdcf0a7d19e88
+DIST h5py-3.12.1.tar.gz 411457 BLAKE2B c8e2bb453b9f7f1a79b9061ec3564bd8f1175c286a163b43f340cb9fc93f0e279131e4ed658066b870237046766aaff1289f22d84ee318108c96840d257baafa SHA512 a96dc5b7a14408c73db3ef758e0d3cff5d4469d6efe19a71af69e049f434aa62f01fbf44464cc5a3d15b89f00b9864cbb42b1b1e59bf3f520b458007f8819cd3
EBUILD h5py-3.11.0-r1.ebuild 1383 BLAKE2B 1061565c3f050996739f1b73c9a1448719c3acb49f856046b09e715c23e059d9b3967886950ce4194235efb1023d6beb4c9f301ea2c47fc1567b27efc409b9e1 SHA512 8ed6a2fc1838be40538075b1c3d3393d46165f8869d0ec5a3fb180febe59a069b640591f43b30e759d5da14b1d2eb1fbbc25601ee2cb692e4d3715b4d7a7a9de
+EBUILD h5py-3.12.1.ebuild 1332 BLAKE2B 7d0d53de0e672d25120bd09d7feda40a8b0801d7ff2454fd7082d6743f49a6ec4cc5e8d35b849bf99520716bd71c20388c5235be9f06d7d3432222ece7701b77 SHA512 955255d82375b1fe1a7c7fe5139ebae319f643821245663dd4bb8243a7221d2f038d4f026bef907c2675c6752b6041befad8fb87a35181c4d1eb0153d0306a0e
MISC metadata.xml 1069 BLAKE2B 0f3ef8e7af7f4bb493824427a238588c019c04c28fe8a4b9c0b9af1c986158eb3dae3b7d7937713cc4c87374ef80686603ccdbae2baff5b1150d814ab108d973 SHA512 47a6074e383cc922234ebb9f67aaa5863421eaeb2003444587bb8499b3bf845da93ac8d8d267717bea01300691df10f67c9389248fbe228afe07c17fba3a64f3
diff --git a/dev-python/h5py/h5py-3.12.1.ebuild b/dev-python/h5py/h5py-3.12.1.ebuild
new file mode 100644
index 000000000000..fae61ce66d1e
--- /dev/null
+++ b/dev-python/h5py/h5py-3.12.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ >=dev-python/numpy-1.17.3:=[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.10.4:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+BDEPEND="
+ >=dev-python/cython-0.29.31[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}