summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/h5py
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest3
-rw-r--r--dev-python/h5py/h5py-2.10.0-r1.ebuild25
-rw-r--r--dev-python/h5py/h5py-2.10.0.ebuild63
3 files changed, 15 insertions, 76 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 3f258fcf6809..111aea829e9c 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,5 +1,4 @@
AUX h5py-2.10.0-tests.patch 1090 BLAKE2B 2c915f28055d6368a5bd43b281d61879e91ae4506e2038b17c7111bae9ebecbb8eb5ca2a2cb8c32b2f6c8cd7c0629cffd926774c3d995fbd0fb6ad09db8c4310 SHA512 7ee887648d025d994eb6e495bad7ab41f7b8c2e9bb65800d9c34c1e31fc1020455202bac87c7cbf2a037a68c7cac43704f02074ae4396053ae03694fab949314
DIST h5py-2.10.0.tar.gz 301057 BLAKE2B 2e9da02224493b79b2df75ff9aa5cb16ab668d07bb95066356749be09091c54032efb3db8b53bdf0fbbbac2bcde532f9f051627327dcf3f35fb578b701ecc165 SHA512 c49b04f7dcddf03f36d4f063d79ecbe544e0b1daee432d4a76cfa83dac3a1f2cb144f40a74fb85ea17cb5b778f57f709969ea5d1a2afc5bdd5aecbc9d732898d
-EBUILD h5py-2.10.0-r1.ebuild 1583 BLAKE2B 0c84f503b30233f78e7a5f4534909153ede1c0d60bd8a93de346573d2e0413168dffe16e2bd98e9a8538c40891c56aa616c91c2446faf021275e46400a36d93c SHA512 911cb64690c4a61fe30f1ed8df23f979e359d7854dcaf35967760021bf83d2b7a70fde945f119ccb2938b22a39d8cdc37e05f285f6355712944c2c8d362ebdf4
-EBUILD h5py-2.10.0.ebuild 1444 BLAKE2B 33f6fe1ec2965ba813db74d215049135b8bed3f02aedf9d3958ed4a1b3e53a738ee4f68c0ba7bc23e982c595d1e4d18b88623e0884c96d70af3f0edb2fb8e4b5 SHA512 0f74c2ce5ea0736339039c751026530cd61d96eb4c45c0d69aa2fd583a0dc9db08068041ed3dfd656811dd5d614396b3f7b73ec4610529016c4a1b29a1da149d
+EBUILD h5py-2.10.0-r1.ebuild 1603 BLAKE2B 6a2266faa0997f41b39f92dbba0d41c6b9fea246e4aec005af71ae3f473d73f7cc170e1dcde749898e645ff21425106c46de067f8be0491e1b6fd520d0652dd8 SHA512 4b7d31cb0fccca70a65d1dd474d5991a1f694a2344e39ddbcbc91b23044ddb43ca815d4d0efdfb959910cdf9747030bece832e80e37927aef3ca0333a61331a4
MISC metadata.xml 1015 BLAKE2B 4b62b6e3d38b745ff2e27bfdd14e6ca380264089c9953e09e6f8c12e223fc9ad45072b8c884ee9a7c24329a00e71a93207d3ffb21b17e8377bf195fb20b54ad1 SHA512 1880b779b8917357e6301273a304314e73686cea70325c2ee17c1bd901190bf0b07575584275039d199df6b190df9be3ab6617ee9f2babb0b609c408cba5af52
diff --git a/dev-python/h5py/h5py-2.10.0-r1.ebuild b/dev-python/h5py/h5py-2.10.0-r1.ebuild
index 4196ed179b15..5ed817404c4d 100644
--- a/dev-python/h5py/h5py-2.10.0-r1.ebuild
+++ b/dev-python/h5py/h5py-2.10.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 flag-o-matic
@@ -11,30 +11,33 @@ DESCRIPTION="Simple Python interface to HDF5 files"
HOMEPAGE="https://www.h5py.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-# disable mpi until mpi4py gets python3_8
-#IUSE="examples mpi"
-IUSE="examples"
-
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+# disable mpi until mpi4py gets python3_8
+#IUSE="examples mpi"
+IUSE="examples"
#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
-RDEPEND="sci-libs/hdf5:=[hl(+)]
+RDEPEND="
+ sci-libs/hdf5:=[hl(+)]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
BDEPEND="dev-python/pkgconfig[${PYTHON_USEDEP}]"
# mpi? ( virtual/mpi )
-DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+DEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
doc? ( dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( dev-python/QtPy[testlib,${PYTHON_USEDEP}]
- dev-python/cached-property[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ )"
# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
-PATCHES="${FILESDIR}/${P}-tests.patch"
-
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
DOCS=( README.rst AUTHORS ANN.rst )
distutils_enable_tests setup.py
diff --git a/dev-python/h5py/h5py-2.10.0.ebuild b/dev-python/h5py/h5py-2.10.0.ebuild
deleted file mode 100644
index d524e809356c..000000000000
--- a/dev-python/h5py/h5py-2.10.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="https://www.h5py.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-IUSE="examples mpi"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-BDEPEND="dev-python/pkgconfig
- mpi? ( virtual/mpi )"
-
-DEPEND="dev-python/cython[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
- doc? ( dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( dev-python/QtPy[testlib,${PYTHON_USEDEP}]
- dev-python/cached-property[${PYTHON_USEDEP}] )"
-
-PATCHES="${FILESDIR}/${P}-tests.patch"
-
-DOCS=( README.rst AUTHORS ANN.rst )
-
-distutils_enable_tests setup.py
-distutils_enable_sphinx docs --no-autodoc
-
-pkg_setup() {
- use mpi && export CC=mpicc
-}
-
-python_prepare_all() {
- append-cflags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- esetup.py configure $(usex mpi --mpi '')
-}
-
-python_test() {
- esetup.py test || die "Tests fail with ${EPYTHON}"
- # tests generate .pytest_cache which should not be installed
- rm -r "${BUILD_DIR}/lib/.pytest_cache" || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}