summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
commit1f23f671d001ca7a0073e504f5ae0184eb5d024d (patch)
tree6747e05170df64a1585f36519a780db2d90f2a11 /dev-python/h5py
parent98bd6c82c526d2c4239d3d194fa1a1a818784552 (diff)
gentoo auto-resync : 24:01:2023 - 12:57:16
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.8.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 08d006d8d7a3..1722bdf977b5 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,4 +1,6 @@
AUX h5py-3.7.0-types.patch 1285 BLAKE2B 13433f524dadbff797fc1668d0ac2954867d3c9c7e56e7f09137b5f180545981620498ad2504c2523005c73dbd61510475eb0874f2d880926b31632f2d978c27 SHA512 d7abc39ee2b1399b0f656e91944ee471f89d0030eb0378dce68232e70209b609c2cf9e62124e4124cf0c089584865357321dc5a641ccb33dbb27f97ad885ccde
DIST h5py-3.7.0.tar.gz 392355 BLAKE2B efc974ff14457ef00329c6b2adf5b926e2dff33bbb4b9e9d60773760a973214c5279bfafca87c6fcab02bbffb85b780c708d26fb55a1e7a401d8d676f20acc15 SHA512 c10a9a623c88dbc965238cb2057b8924492c762c29610cfdb24f26f878a7322e414d3e5c90d750c2f5cfe1b4949f884bc17f09a126b01a4721ad6e14761174a2
+DIST h5py-3.8.0.tar.gz 400774 BLAKE2B 2e48991225170fbb728fa55a68aea795db42c7eae605d123a24a59a8730220ddc98e88dfbff60220ce8c6952ca7fc0c3e33d472acae09864a29bfe11d90fcca1 SHA512 13397f66a9fc735e1143eb9e3dd584280e955adf49de467bf56c1a98952903720480ab8d505921b7e22c16453498625ad93421a64e520f15ea3566472849a8fd
EBUILD h5py-3.7.0.ebuild 1530 BLAKE2B 9ebe99b9f990f8d4771ad6afffe78993c0a8a483c927d35a2b097be870fd4803143f2720df44a5ed1d677922f924a4542e3b64d500314b8947b48a0a46389938 SHA512 8c97aabb14491a3d8d60c19f94634508427878508f2971887db3c62cd42a6d0d96ece36e3f58cc27d53fe8655ef3b895bcc9c9b267950cf537839000ba4d9a15
+EBUILD h5py-3.8.0.ebuild 1478 BLAKE2B 45d91af73ec4ec38b09a295c508b7d5906415c570c7fd2435a522c2b52da8dbc02a2ab238774a8359b4ac40b1e257b430e8b7ddb90dbf3a5e3f747c3d8a49e7b SHA512 fe769cc89f58c15a16fdbe4e34d33f9eaf047d1bbffcd5324c634f5cc236f1f21548debb69f195f9e95dbc43d6d67dc8e253dd623acb96a7b1a3880d2d2070c3
MISC metadata.xml 1069 BLAKE2B 0f3ef8e7af7f4bb493824427a238588c019c04c28fe8a4b9c0b9af1c986158eb3dae3b7d7937713cc4c87374ef80686603ccdbae2baff5b1150d814ab108d973 SHA512 47a6074e383cc922234ebb9f67aaa5863421eaeb2003444587bb8499b3bf845da93ac8d8d267717bea01300691df10f67c9389248fbe228afe07c17fba3a64f3
diff --git a/dev-python/h5py/h5py-3.8.0.ebuild b/dev-python/h5py/h5py-3.8.0.ebuild
new file mode 100644
index 000000000000..2eb6cdb7db99
--- /dev/null
+++ b/dev-python/h5py/h5py-3.8.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+# disable mpi until mpi4py gets python3_8
+#IUSE="examples mpi"
+IUSE="examples"
+
+#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
+DEPEND="
+ sci-libs/hdf5:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ )
+"
+# mpi? ( virtual/mpi )
+# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+#pkg_setup() {
+# use mpi && export CC=mpicc
+#}
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}