summaryrefslogtreecommitdiff
path: root/dev-python/h2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/h2
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/h2')
-rw-r--r--dev-python/h2/Manifest3
-rw-r--r--dev-python/h2/h2-3.2.0-r1.ebuild58
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild19
3 files changed, 77 insertions, 3 deletions
diff --git a/dev-python/h2/Manifest b/dev-python/h2/Manifest
index 736aff74f748..eae15673875a 100644
--- a/dev-python/h2/Manifest
+++ b/dev-python/h2/Manifest
@@ -1,6 +1,7 @@
AUX hyper-h2-3.2.0-failed-healthcheck.patch 3381 BLAKE2B 0eef97897e58ca0b580371e1cd8dfeb4c85d3e333aea4566121bbabd08cee5a46070360e3f40f244058082c5949f3fc1ed8c5a9d80bdc6f9c7ce741a9dfa915f SHA512 0e5e9a6f3380e3a2b54f63c9894e3fd5c5987b7e55834200b051e6d8ed13219f9784340275ff136ba273eb5b989b5bed80e85460bc7b25049974150f0340911e
DIST h2-4.1.0.tar.gz 2143812 BLAKE2B b9d9a771340b4bde1675b9fd65c242732a1a262456f84a409662cf2b57326e24e0583160ba0531c0b105b79342578714127dddb560d2a27de58af34d1052c698 SHA512 4e9cf88b3ae702a8a42bded775ad337809787fe8172d501c230d55abbf1edd764acf3b227f2e58756d882499661ffcf6bbdd4812a4d938c04fac3f1aa2390b28
DIST hyper-h2-3.2.0.tar.gz 2203333 BLAKE2B 245bab162852070e850613c41162c75efe5e43535945dacf448afdc948cade83402f77259aa46f375d0772a5287e42d8842b1259cb36392cc8fc222dec7cef75 SHA512 103a4ea2cd29037ce03ae676864125b4111c7d31a82bbbe7028557da886d88fb5363d885f08d5d3f68dfa29013b7b03350cc0cb4d9dddf32735e98dae5d7fc7c
+EBUILD h2-3.2.0-r1.ebuild 1679 BLAKE2B b99e6d232b30f0ddd77f09b816b3ac97bf29adc9ff3922086e56e4a83ee989824073f43a08428517932913134abfbf90454c5c7391d9c01efa5a7fbdfa6f621c SHA512 15d16c1639212f74ba782e51941d82d99c14bc12feab97dd1d2692133aec5a7625931cfa0eb92fced81907114e75909a1892276d71771705089a38012ccf369a
EBUILD h2-3.2.0.ebuild 1598 BLAKE2B bbb1bf40b9a8867e30d01445fbf84b21cc88ed08fcad635d43ab9bf41b1a69e031d762d14664c4b56c3886b850f7efb829d9453f580dca075f6c70b1a0ab0422 SHA512 2f8cc85700b3fb63f848db74eed1d893418179f9b7bcc989db48b5f206e16c40a088dd519a3ef6b903d80868b98845a853e8f2e3e57ade7938918e1c1f40e08c
-EBUILD h2-4.1.0-r1.ebuild 889 BLAKE2B 8ccb3149add276e155521e099b02ac02d9a4bdc4ffe861fe154f434d14866bf54991ef2826606250869bfce3b182bc5d8b8609e40c1a919640393da2f67a914a SHA512 9654f20c46815e0ef306a588bd470e7f3b95cf254d1fb31e0fba52392af8670c6d89a307d4482b81c0cf8cf9a2aa8ad13694bb123e3c3a67aba146e4df056351
+EBUILD h2-4.1.0-r1.ebuild 1293 BLAKE2B 103028d47b96ce622db5ca9ba314cd316da477a72b2f2c6ea32cea8380a6a1222f5a556f4acee593947981f3220b7749ad09cd621af5def2ab68b9dae08f8abe SHA512 51f695d21c215ae9bbeaa0de0d017e95d19f5d490ee3686074843c6a3f91fae29dbb9299e532afb58662fe8872f0b4730b94c8f6d63bb69eb7026d3d3e6b84ae
MISC metadata.xml 694 BLAKE2B 8e3c231ed6263fd0feba3f8f3ef0d5cf0345e2de092e4a50de3d6b9dc3b009570b896dc5a7804f9b99e9ffd75ae6a8387d139f0db1dc3ce213c4e7bca63061e2 SHA512 713b15d6f84180c861d1487f2ee7a377acd9403876385e064bfb103b5961cc53655953602dfc809cef648444ea9e201991e2de00203d0ab5a36c3d13b1764e2a
diff --git a/dev-python/h2/h2-3.2.0-r1.ebuild b/dev-python/h2/h2-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..46613c45aa92
--- /dev/null
+++ b/dev-python/h2/h2-3.2.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=hyper-h2-${PV}
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="
+ https://python-hyper.org/projects/h2/en/stable/
+ https://github.com/python-hyper/h2/
+ https://pypi.org/project/h2/
+"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # From https://github.com/python-hyper/h2/pull/1248
+ # Disables some failing healthchecks
+ "${FILESDIR}/hyper-h2-3.2.0-failed-healthcheck.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == python3.1[01] ]] && EPYTEST_DESELECT+=(
+ # these rely on fixed string repr() and fail because enum repr
+ # changed in py3.10
+ test/test_basic_logic.py::TestBasicServer::test_stream_repr
+ test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
+ test/test_events.py::TestEventReprs::test_streamreset_repr
+ test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
+ test/test_events.py::TestEventReprs::test_connectionterminated_repr
+ )
+
+ epytest --hypothesis-profile=travis
+}
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
index cb38a68436d4..2520745f3814 100644
--- a/dev-python/h2/h2-4.1.0-r1.ebuild
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -12,7 +12,8 @@ DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
HOMEPAGE="
https://python-hyper.org/projects/h2/en/stable/
https://github.com/python-hyper/h2/
- https://pypi.org/project/h2/"
+ https://pypi.org/project/h2/
+"
SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -32,3 +33,17 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
+ test/test_events.py::TestEventReprs::test_streamreset_repr
+ test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
+ test/test_events.py::TestEventReprs::test_connectionterminated_repr
+ )
+ fi
+
+ epytest
+}