summaryrefslogtreecommitdiff
path: root/dev-python/gwcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/gwcs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/gwcs')
-rw-r--r--dev-python/gwcs/Manifest4
-rw-r--r--dev-python/gwcs/gwcs-0.7.ebuild51
-rw-r--r--dev-python/gwcs/metadata.xml20
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/gwcs/Manifest b/dev-python/gwcs/Manifest
new file mode 100644
index 000000000000..fea9516eb064
--- /dev/null
+++ b/dev-python/gwcs/Manifest
@@ -0,0 +1,4 @@
+DIST gwcs-0.7.tar.gz 276681 SHA256 ad1cb88de858a4174d97c50a045cc7a4317c615a95c70ff5243a55431b0278cb SHA512 fe7b11c748f76175ea7a3d0a584ac61d783ef06db849c7dc77f220e40e8e9f44a5090f3f2de50a51d0df66e04f7aec32aac14fd406d4d41d32d70c53f04a9961 WHIRLPOOL 93265da283643487e189c573e6b052c08638b1a34c2e096151d507b26bb269259cade121896bdfcb2723fa923845079c02f277c08d1501d9eb72393720426b7d
+EBUILD gwcs-0.7.ebuild 1311 SHA256 e94167681f2b910c6b5dad9a5c45122d128ce0054af342ecc22aa2ffa9d554cf SHA512 79bab4cc5eefd42523fac6a041ce7ab2f70208e4ec836cf632099ac189d7348c7041967ac54c2ff195b286be0c0e0f5f62c44aede4a4006d71bedec48f90bf69 WHIRLPOOL 8fa01edf5a27d84d77ff3921d46d6c5bdc4a27a485b2c262ce39716b84c425a75f35b72404a4b9d906f9b6f1c3d1d52ee252c3321011901ec1916b4436c5531f
+MISC ChangeLog 310 SHA256 aa0417e4d7aa899200b162f576d28369653658f25a455ce9df3bafcab98ee8b3 SHA512 ec079c4c82cfd9866c46c603c48565b5983775cac4dcd92c1d6bc1ef3a001e1d46148cd017e2d4ae53d178276d390dba0f04d86959759c82388b95be0ce44693 WHIRLPOOL b0b95028acab0a0f96b71641d600fbbc691cbe91964869ffebc476bbe40fd549ceff52509d1896c6d0d922da8ce92b131899dd82617fac2a3843f1e9262c996d
+MISC metadata.xml 801 SHA256 530a852bd3ad7e06a9ff60f65e9fa451da4d8b90be524a01e35917e56dcbd952 SHA512 9a20c6faf196c7076f94c28ff3dbb1c63ba144b799b6d4c35051afb39d3cf90247bfe38fcb5ec4a53f210d629f5d86c38282eeac3cb24913d1cab0fa58e2c273 WHIRLPOOL 345bd9c244a411979974291c801c5146e6fe52c0ada64f8443833bf036112fe0c89b1e52c6539c0e086d096f1fa818eef615aa55dc190888e6651d96e8f5107c
diff --git a/dev-python/gwcs/gwcs-0.7.ebuild b/dev-python/gwcs/gwcs-0.7.ebuild
new file mode 100644
index 000000000000..f778cbb6d015
--- /dev/null
+++ b/dev-python/gwcs/gwcs-0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python for managing the World Coordinate System"
+HOMEPAGE="http://gwcs.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/asdf[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 )"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${PV/_}"
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gwcs/metadata.xml b/dev-python/gwcs/metadata.xml
new file mode 100644
index 000000000000..033a8d077fdc
--- /dev/null
+++ b/dev-python/gwcs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ GWCS takes a general approach to the astronomy World Coodinate
+ System. It supports a data model which includes the entire
+ transformation pipeline from input coordinates (detector by
+ default) to world coordinates. The goal is to provide a flexible
+ toolkit which is easily extendible by adding new transforms and
+ frames.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">gwcs</remote-id>
+ <remote-id type="github">spacetelescope/gwcs</remote-id>
+ </upstream>
+</pkgmetadata>