summaryrefslogtreecommitdiff
path: root/dev-python/guessit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/guessit
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/guessit')
-rw-r--r--dev-python/guessit/Manifest4
-rw-r--r--dev-python/guessit/guessit-3.4.1.ebuild36
-rw-r--r--dev-python/guessit/guessit-3.4.2.ebuild39
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/guessit/Manifest b/dev-python/guessit/Manifest
index 606ece2b8dd1..d75e879ccfc2 100644
--- a/dev-python/guessit/Manifest
+++ b/dev-python/guessit/Manifest
@@ -1,3 +1,7 @@
DIST guessit-3.3.1.tar.gz 156178 BLAKE2B 190b61eb98c4945eb2e14bbc3387a2eabff4e0f2fccf42f3b957d2b081d83d96333f3931837ad77d6b09c12aaa174eb8adf993d62ab9de7b74d8f0c55282a77c SHA512 42c87525ea2d9c808e30b50db674862f5362f26b95ba5e6bc163df03a261d9b24daf4b4d525677d3e6d53e8e7f637c3d9e0ba3f25f4397e0658b618f50a3248b
+DIST guessit-3.4.1.tar.gz 165594 BLAKE2B a05b272efd3304dc7f9e1ae6bc6595e5dc43a1cb68d96cebcd2817deced508cc24771235bcfb4dd9aec7aa41857cde138fed110e3b921aca7dc8cc15f750ba0e SHA512 2e42f93d4302f9586015bac9b11ebf0fd819305e02b869b6f398f494c0a979fd7d6857f9e036656d419c937e3f723a80cf0211ae1068edbfa3c7f9e1fdce182c
+DIST guessit-3.4.2.tar.gz 165996 BLAKE2B ccad7018ed54a49397ff008555650bb322f6884ece0608a26af89ec58d82e81125ca806b18a9936b578626a0b47f8b4fae3a3b9299cfebd67c29e88e05cc7785 SHA512 e969ed2d89e3b0eb1f70db3d8fe5258c39f4c9f86dfb7f943c2fc2c4d8f85580487921b7ee37e486bf1f8dfc067b3a2a75a54a2e72519b9687aae48ba7631c6e
EBUILD guessit-3.3.1.ebuild 996 BLAKE2B 07f96a459104bc8a2cd47a7018e73dd7de777be3f37d5719ac6de375d6bb4146c7a917747847915fb019005520d3704c16855c2b9619939cf8b221f34ba52a52 SHA512 8c575648ad639a2ad97c327207919466b54f8862ceae2699f4b6b1a4cb90ed69afa412705ea802695fd08a18d22e20bda5ba1493aa6ef04c2b04dd0e881ae1b6
+EBUILD guessit-3.4.1.ebuild 998 BLAKE2B f16a3985c89aebd8b4013cecab05c3fd14493973ef51e0a9115d681053ade11e60deba65f2bad5772e5bb12c2e964e7af31a510634193eee5cc007c048a5208f SHA512 0d68cea5f913eacd7522453d9baa5d7a3e62ce287fa5278fdbc2d1d1bb00e3c891015b4e230634712bb7410f889ffb18d5e22ea1384098882faf931d85cce5d1
+EBUILD guessit-3.4.2.ebuild 1094 BLAKE2B 5e63ee67d7d8bbbf45f72bfc9099128fa5c2f0079a972ea851f8710b154b0c6fc12faf46aac4421c1b5342ab3f98c199e5496582d68b956d2666c5dab3bc019a SHA512 2bc1c78f11c5578e41a8b3f482d6b8159387210bac9c08248e72aadb901964d14816c67845fb8a65d3af38c91e2989969bc56ae501b411044c0f96b960f29e4b
MISC metadata.xml 393 BLAKE2B 6aaa0bb7a7cac0915e2aa2d65bbc311144f5ac04ace0abbf5591f94d7e4b50c80754d9ac5d92039fb0494ebaf4051fcd9d0de60f208fcad3fb4fec521503a7d5 SHA512 02502c60dec90c160d8bdb29223cf27bf0ea6e23d01b3feb336f747e13c0c830f788e1b42fede862706d7b45927f08f3c8bc124dd8bac7c94264a0659a9df9c9
diff --git a/dev-python/guessit/guessit-3.4.1.ebuild b/dev-python/guessit/guessit-3.4.1.ebuild
new file mode 100644
index 000000000000..3570c4dabd81
--- /dev/null
+++ b/dev-python/guessit/guessit-3.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit
+ https://pypi.org/project/guessit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/guessit/guessit-3.4.2.ebuild b/dev-python/guessit/guessit-3.4.2.ebuild
new file mode 100644
index 000000000000..9eaa73f85cd4
--- /dev/null
+++ b/dev-python/guessit/guessit-3.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit
+ https://pypi.org/project/guessit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}