summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/gst-python
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest2
-rw-r--r--dev-python/gst-python/gst-python-1.18.4.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index e7965b6144f8..bcd3063e94f2 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,5 @@
DIST gst-python-1.16.3.tar.xz 419932 BLAKE2B 3c3d7d8dbde7d77d57e340c68503c436ab03f8768be4dd67561b13712bf88d7f8025118cf6a2ff115fbd41b28dc9a3208f612d1b72bf449fd7b23be4437f837f SHA512 2b038c4fc4891ddcf09e58c9e3e8d8462c150589dbb8a1f8d0a1266cffe49fd83531b2eb97cd57baab0f416a2bb1ba81383b55bb953545f3eedc50b6895986c4
+DIST gst-python-1.18.4.tar.xz 158252 BLAKE2B 2fd60d2d451ae572cee2f7e9158e9c06e82cdd56c4fc70d2731aa0a46a21e495321ec02c97ecd9a946278ce9b7290a290b9f2bc13184582c1f8ff19e874d0e3a SHA512 6b9df9e4faaeb030f0596c9e52262c0f82b8854faf821497a840a762913dccb005321c60565754ef571e34976fcda481a41aefbbd486c2932377a95121433bf5
EBUILD gst-python-1.16.3.ebuild 1556 BLAKE2B 5a5f9dc90cdbc2262f226b00ee166afd8b8df17c64714694ddc73c87c96a06e537dac794a627d94a1f8874ec5adab74be1dc790e494a48b97f41c9e3134f5240 SHA512 d9663bb501c02dc98be963bb6ba6f4dc514154460084de9cb9d079da1af11daebe2b54f575461707024ed2627d6ea44f5897fb981c2463c3c8e07356fcfbd371
+EBUILD gst-python-1.18.4.ebuild 1630 BLAKE2B 3ef067bd8726ccdde935fd02b5b0608f708a58ab7a40f1d2e416e643da06b7c40992dfd32a43fd518086933e3b427339a3b1f4fd79b0a13cb197a87ff0ad6c5c SHA512 06ed5d9fa116793874b1e73706d21514dc74026b0cc7a592b481f3f941809423ab25dae596607cab8fd38afc918ffe9de1906ad6b9a1bf1f894f3cfe3446ea26
MISC metadata.xml 266 BLAKE2B 3180109d2a1479e9436a76fb478dfb1b23db0daedbf0ef264a469fbbfecd858adf6ec01f3fdc5c56270d0a9e1e150ac947f4a1f893e967d6b1dc1f1b8f6d4ccb SHA512 aa2ce82fa0c848119ff309462722e1d7897da904f9e1dc9ae12dd61582823b69cf5a40faf8da0825ec397d2f01d44e82cb56730d9545abd619a17696091eca75
diff --git a/dev-python/gst-python/gst-python-1.18.4.ebuild b/dev-python/gst-python/gst-python-1.18.4.ebuild
new file mode 100644
index 000000000000..14626ea03c5e
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.18.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_8,3_9} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}