summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
commit0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (patch)
treefca9d00e42cd967e466d66fd8d23d3bcee39cf75 /dev-python/gst-python
parentc3d998909264b1ff687b9c65cae3046443e66f7e (diff)
gentoo auto-resync : 26:08:2022 - 20:52:47
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest2
-rw-r--r--dev-python/gst-python/gst-python-1.20.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 860531fe1ea2..c8410a24e397 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,5 @@
DIST gst-python-1.20.2.tar.xz 153428 BLAKE2B 051be5996530989b0e016662f4bf33ac01d576dff56ef779ae481f6f02143595cb3132b9a1ad56cd26f7de55c5df28d25cac448ef28f1b8595974f468252c6b5 SHA512 99af8bad76f930e6c11dcacac013ffe30670ad77259ebe96ee6059a9c359fd1a9c9b22188856f2f19f31469c152b3ad269ba821d06ef92f0c92b3b0fe0eac0d2
+DIST gst-python-1.20.3.tar.xz 155504 BLAKE2B 2991f106a53da6e968bdbf2b081c464e92902e4b5ed57e7a14ef1c1556ba18d2e63f4402e703953513f68c36405478b0da05f283602f564bec16cbe72b9e686f SHA512 987b444d78b5fb206457245b46b843db9372f9bd316abc57ecd8d50488ef734707a08ac88a9b9d58e2db113e67ce5b524aad82c0086471494c2177c2e272de6e
EBUILD gst-python-1.20.2.ebuild 1631 BLAKE2B c365d5b9958e7f95f2c78e5e29b5d12589526b8e5be98c78e810872d8fe332250aed63e4e51ca25e45a9dc894c7d9151d762ec595848a064541af3eb78f9fed1 SHA512 4d82a2a5def91828763c71099eea382c407fd84d5dfc8b1c3eb76deaf5bc8563171f050d2db4fde2d830c64af94217fb489e7dfc87b0bbb97de1f1eddd23d3b4
+EBUILD gst-python-1.20.3.ebuild 1637 BLAKE2B c58fbc16ef1dce5236e8a6dbb326cac3aac4be3d85a7faf349b5984e5545ce25e420533fbbfae582f60e3dfbf9be2d80462d0d5e85fc875a8204741a27ded058 SHA512 22afc8437c0627599779f923cad9c2f0f9e6b0a04f4a244b997f7f5e9166758b7f52d82ffb40e4e64f275f154d6d1ad6dc30300030bf5f17963d916cb5e44bef
MISC metadata.xml 267 BLAKE2B 331be70b2fa90cce1bf91ded1dac141de6a9bec40c1736bcb90d280ac7fabf22cfd0a701c7fd5864f007d1159954f7ee55701d5e68b47a1a9a217ca34b7ee619 SHA512 4dcdd6bc6d148a0e02a0f1b766bd0c5712d373d898c06078d8630e0067e858b815117392a11332b257156e95da6337494d99c2724d24cadb97432089908644b5
diff --git a/dev-python/gst-python/gst-python-1.20.3.ebuild b/dev-python/gst-python/gst-python-1.20.3.ebuild
new file mode 100644
index 000000000000..5df02dbb593b
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.20.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}