summaryrefslogtreecommitdiff
path: root/dev-python/gst-python/gst-python-1.20.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 12:17:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 12:17:26 +0100
commit41c2683a5cfac2bd3280dc5d5aaed73b6c377bcf (patch)
tree05752a3fb2f0dba34c0384a9178c0fd4c5b3cadb /dev-python/gst-python/gst-python-1.20.3.ebuild
parent3b0753af8a3a0f5ac9f7248d90393dcc0d3a84c1 (diff)
gentoo auto-resync : 13:10:2023 - 12:17:25
Diffstat (limited to 'dev-python/gst-python/gst-python-1.20.3.ebuild')
-rw-r--r--dev-python/gst-python/gst-python-1.20.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/gst-python/gst-python-1.20.3.ebuild b/dev-python/gst-python/gst-python-1.20.3.ebuild
deleted file mode 100644
index aa96e5abef4b..000000000000
--- a/dev-python/gst-python/gst-python-1.20.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit meson python-r1 xdg-utils
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="1.0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=media-libs/gstreamer-${PV}:1.0[introspection]
- >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
- >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
-
- # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
- # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
- # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
- sed -e '/subdir.*plugin/d' -i meson.build || die
- sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
-
- xdg_environment_reset
-}
-
-src_configure() {
- configuring() {
- meson_src_configure \
- -Dpython="${EPYTHON}"
- }
- python_foreach_impl configuring
-}
-
-src_compile() {
- python_foreach_impl meson_src_compile
-}
-
-src_test() {
- python_foreach_impl meson_src_test
-}
-
-src_install() {
- installing() {
- meson_src_install
- python_optimize
- }
- python_foreach_impl installing
-}