summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
commitd5c5aa9b48bd6a821f5e0a1a98474ac35fb21360 (patch)
tree9de3699cbe327fb5dd93a6ec37b895f9fdb94494 /dev-python/gsd/gsd-3.1.0.ebuild
parentc6a12f3c8604a9269cfb82d666fc716df0e67792 (diff)
gentoo auto-resync : 29:07:2023 - 04:38:40
Diffstat (limited to 'dev-python/gsd/gsd-3.1.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-3.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-3.1.0.ebuild b/dev-python/gsd/gsd-3.1.0.ebuild
new file mode 100644
index 000000000000..c9851b2e7559
--- /dev/null
+++ b/dev-python/gsd/gsd-3.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}