summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/gsd/gsd-2.9.0.ebuild
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/gsd/gsd-2.9.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-2.9.0.ebuild b/dev-python/gsd/gsd-2.9.0.ebuild
new file mode 100644
index 000000000000..72189439c631
--- /dev/null
+++ b/dev-python/gsd/gsd-2.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}