summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
commitf090ac33320e52dd549b818be0c345a3bb870ae0 (patch)
tree2a93d78a55e094fd70aba050c185671713ca63e2 /dev-python/gsd/gsd-2.6.0.ebuild
parent343082998723d09c7b354eb21ff4793c6d4fda3e (diff)
gentoo auto-resync : 20:08:2022 - 02:37:51
Diffstat (limited to 'dev-python/gsd/gsd-2.6.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.6.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-2.6.0.ebuild b/dev-python/gsd/gsd-2.6.0.ebuild
new file mode 100644
index 000000000000..f0c47aecddbe
--- /dev/null
+++ b/dev-python/gsd/gsd-2.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}