summaryrefslogtreecommitdiff
path: root/dev-python/grpcio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/grpcio/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/grpcio/files')
-rw-r--r--dev-python/grpcio/files/setup.py-respect-cc.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/grpcio/files/setup.py-respect-cc.patch b/dev-python/grpcio/files/setup.py-respect-cc.patch
new file mode 100644
index 000000000000..545346e8152e
--- /dev/null
+++ b/dev-python/grpcio/files/setup.py-respect-cc.patch
@@ -0,0 +1,33 @@
+From 0a6c58fc0161e697bbf64b4f3d4ef14b03ac186b Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Sun, 7 Jun 2020 23:35:31 -0700
+Subject: [PATCH] setup.py: respect CC variable in latomic test
+
+some configurations do not provide generic cc binary.
+while rest of the build calls CHOST prefixed binaries,
+this check fails. fix it.
+
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ setup.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2379703eb7..0f92270607 100644
+--- a/setup.py
++++ b/setup.py
+@@ -144,9 +144,10 @@ ENABLE_DOCUMENTATION_BUILD = os.environ.get(
+
+ def check_linker_need_libatomic():
+ """Test if linker on system needs libatomic."""
++ cc = os.environ.get('CC', 'cc')
+ code_test = (b'#include <atomic>\n' +
+ b'int main() { return std::atomic<int64_t>{}; }')
+- cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'],
++ cc_test = subprocess.Popen([cc, '-x', 'c++', '-std=c++11', '-'],
+ stdin=PIPE,
+ stdout=PIPE,
+ stderr=PIPE)
+--
+2.27.0
+