summaryrefslogtreecommitdiff
path: root/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
commit56767705335e747c2a8b3f3282e5c1a393352d54 (patch)
treedb29fcdff8c7ce293aa55e7ba797c1242cd601c0 /dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
parentee2ff072f141c81ba073dc664091d2780d4e74e0 (diff)
gentoo auto-resync : 29:11:2022 - 01:18:33
Diffstat (limited to 'dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild')
-rw-r--r--dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild b/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
new file mode 100644
index 000000000000..bb067461a7b0
--- /dev/null
+++ b/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="Protobuf code generator for gRPC"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-4.21.3[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}