summaryrefslogtreecommitdiff
path: root/dev-python/graphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/graphviz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest3
-rw-r--r--dev-python/graphviz/graphviz-0.7.1.ebuild31
-rw-r--r--dev-python/graphviz/metadata.xml16
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
new file mode 100644
index 000000000000..67f612b926f2
--- /dev/null
+++ b/dev-python/graphviz/Manifest
@@ -0,0 +1,3 @@
+DIST graphviz-0.7.1.zip 100779 BLAKE2B b981953160f1978fe62b6c2cf422fcde78cc4de80a5274fd6e59c15f8907b34c68b0413d2c538d507d43bd8761349cd7fe532744d2e5ad737f403e52e1fca7b2 SHA512 e8ba326060ff3039f74902c01cf3d96c9965ce2259d0d5a9594e399added05c7e25b0f6c4b0be9ab21c1d37bbfb69e9c4856a7bb457b545185d48838d34cac70
+EBUILD graphviz-0.7.1.ebuild 660 BLAKE2B ff118dead766f3f0f86b528ea6f5fb08cc8195ff62bbeaaf1ceb7948a4bacce53c6ede6f90bd2b55185fec6f4c8898647e33ca020ca11d52dbc90fac5c9a39a8 SHA512 0b974d48ff314fbcaccf54d1de13fafb6a21cd74d354c05af03f4da9484678f6a5b2bcc647f43c59f5be72c18953c3b1502e42377945db22b3f7f079385e0b8d
+MISC metadata.xml 527 BLAKE2B b9c6fc9921bfbde8dcde78435394cb97b88d65cd6691bffe94d03f5b22127753333a93496b206d7efa7aef31ffce26d7dd212e3f244f9d111bfc006baf4fff42 SHA512 ee156200f5de25536c3de4de57d0cdc0e01fcbf5b3ef8cd0baf15f7aeea29ce178e393c2ff3f409a93ad3dacd099664b9e72c43c259231b59668f08504c21c82
diff --git a/dev-python/graphviz/graphviz-0.7.1.ebuild b/dev-python/graphviz/graphviz-0.7.1.ebuild
new file mode 100644
index 000000000000..a2327f77b8aa
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/pytest-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die
+}
diff --git a/dev-python/graphviz/metadata.xml b/dev-python/graphviz/metadata.xml
new file mode 100644
index 000000000000..f36ba828ecec
--- /dev/null
+++ b/dev-python/graphviz/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ This package facilitates the creation and rendering of graph
+ descriptions in the DOT language of the Graphviz graph drawing
+ software (repo) from Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">graphviz</remote-id>
+ </upstream>
+</pkgmetadata>