summaryrefslogtreecommitdiff
path: root/dev-python/graphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/graphviz
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest3
-rw-r--r--dev-python/graphviz/graphviz-0.7.1.ebuild31
-rw-r--r--dev-python/graphviz/metadata.xml16
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
new file mode 100644
index 000000000000..307a1d38995e
--- /dev/null
+++ b/dev-python/graphviz/Manifest
@@ -0,0 +1,3 @@
+DIST graphviz-0.7.1.zip 100779 SHA256 c7744df945fa90791ad9b4183a6a7dc8220d63a7b8a5f8f93ba62086f1e69e83 SHA512 e8ba326060ff3039f74902c01cf3d96c9965ce2259d0d5a9594e399added05c7e25b0f6c4b0be9ab21c1d37bbfb69e9c4856a7bb457b545185d48838d34cac70 WHIRLPOOL 9d81bfc82d7329e6db586f0ca3c4997446491dc1f413115ec7b4cd28cb31f5827206c3f57bad1b84d6b494d01bf751b516d6be75c4566abb639144fa9e623d54
+EBUILD graphviz-0.7.1.ebuild 660 SHA256 29971b3b60d83a3d8e6c9607e1d1cf0930d5b72e12eb0c663a5a76d779c5704b SHA512 0b974d48ff314fbcaccf54d1de13fafb6a21cd74d354c05af03f4da9484678f6a5b2bcc647f43c59f5be72c18953c3b1502e42377945db22b3f7f079385e0b8d WHIRLPOOL 0d62c7831bf7c1762cf401f86423a1970cd86c5aa4594a615e407d2932345aa4ddbf797314a664f7777e60d0937515dbb7f533528df0ec20211db957667541f3
+MISC metadata.xml 527 SHA256 d8b3d684a3bff008047b74606a7fa635b9f9b196ce6f331404149bcaa7e59c1b SHA512 ee156200f5de25536c3de4de57d0cdc0e01fcbf5b3ef8cd0baf15f7aeea29ce178e393c2ff3f409a93ad3dacd099664b9e72c43c259231b59668f08504c21c82 WHIRLPOOL 31d92d6e49cf877ce96e4a8f1c20546f7beb489bcd6be9728a21b04c8190cfac33ba1e854c1a0c449dd1bdf57edcacc88d62ecd8d6726d52299888cc26219435
diff --git a/dev-python/graphviz/graphviz-0.7.1.ebuild b/dev-python/graphviz/graphviz-0.7.1.ebuild
new file mode 100644
index 000000000000..a2327f77b8aa
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/pytest-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die
+}
diff --git a/dev-python/graphviz/metadata.xml b/dev-python/graphviz/metadata.xml
new file mode 100644
index 000000000000..f36ba828ecec
--- /dev/null
+++ b/dev-python/graphviz/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ This package facilitates the creation and rendering of graph
+ descriptions in the DOT language of the Graphviz graph drawing
+ software (repo) from Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">graphviz</remote-id>
+ </upstream>
+</pkgmetadata>