summaryrefslogtreecommitdiff
path: root/dev-python/graphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
commit22899eb46c1c332d9a8a995c0be0b965fb1bcfc3 (patch)
tree25c77db0aa77917e9d02268c57cdd9fac0d82035 /dev-python/graphviz
parentbf2c6ad6782df5963101bc3e73c0d31d65e0829f (diff)
gentoo auto-resync : 25:07:2022 - 14:56:29
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest2
-rw-r--r--dev-python/graphviz/graphviz-0.20.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 314abff1dfd4..401fa4da3f5b 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1,3 +1,5 @@
+DIST graphviz-0.20.1.gh.tar.gz 188952 BLAKE2B 65d0b993e01492894b6d245c0869412b4956e5d55f9d8d490505c8f3477dc5ab98739cf0bf1aa1a15c4bacb2db4c2807659ce410ca65503c5876ffdc278e959f SHA512 34d340469856777f03b9c9e6d28f232908797bc1456a5b50104dd2f7dc8b7488afc7b29a564d57707ae96f3291f5ae90b8140ab64e378b82f271b5521763fb55
DIST graphviz-0.20.zip 255452 BLAKE2B 0bafa3af9d712e30bd6777d55d54c5a8055f8ad4c6e6ee8c9f936a5abf6e025d7179b2b72e9e0926378ae30e9b655d08507e815c67944123c6c222ecbcd4939d SHA512 8b30ac09913ec5860cf26cfc9e008b0feeda8d61274e346ec305087468b655ace115ff28e0ab96eb47d97127410213729d1131dd635771dcaedfae0bae0ca178
+EBUILD graphviz-0.20.1.ebuild 996 BLAKE2B dd460c91a4c813db57f16c29c534c376e1b15d0716f26e26a2ab6a691f00346572c988bbe239d1eb54e530227066b0fe5d0ecb39a9a8caec55f27598d14fe4c8 SHA512 22d9fa27bdab0df97bbf251499f05b4f4ddd09b62615d53a43b150e9b6b9a9cde6c88f383eb18d350c4fd824dee04ddd17c3735dfeace9b6f47968dde1f075ae
EBUILD graphviz-0.20.ebuild 896 BLAKE2B 6dffb177f1edb1a18d6f8396552754e2ad163b8a7a4f20e71e786f09322dfa33d4ccc418596e801c75c3e1b1be425461f5318575d7c9cf0c56eff235fb575372 SHA512 35806a15b42e71cfec6f755dc692547c755f3345b7405a33949e5bb09529caa0bb7da022bbbc2b6ff0001fd09f1e432a12735ed55118d382ef68f8d13e4e7c3e
MISC metadata.xml 553 BLAKE2B d974f24c488a83d7c1510825d5e157644a4df70113af1283224a847d1cce2535ff4cb0633833a8671f6508fdd38c9079bc21239fdc1d1e9ac85f2ad08ea3a297 SHA512 72d2ce4887aa23136d689bf51b94f17ea3c8803464f623b0f4380381b9639a15a34858f26f129d5db2025d2ccda82dc80f22f5984ef58cffdf4dfcd7b8c51127
diff --git a/dev-python/graphviz/graphviz-0.20.1.ebuild b/dev-python/graphviz/graphviz-0.20.1.ebuild
new file mode 100644
index 000000000000..a0d7db4398ce
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.20.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="
+ https://graphviz.readthedocs.io/
+ https://github.com/xflr6/graphviz/
+ https://pypi.org/project/graphviz/
+"
+SRC_URI="
+ https://github.com/xflr6/graphviz/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" run-tests.py -vv -ra -l -Wdefault -p no:xdoctest ||
+ die "Tests failed with ${EPYTHON}"
+}