summaryrefslogtreecommitdiff
path: root/dev-python/graphql-core/graphql-core-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-python/graphql-core/graphql-core-2.0.0.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-python/graphql-core/graphql-core-2.0.0.ebuild')
-rw-r--r--dev-python/graphql-core/graphql-core-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/graphql-core/graphql-core-2.0.0.ebuild b/dev-python/graphql-core/graphql-core-2.0.0.ebuild
new file mode 100644
index 000000000000..d73013847a56
--- /dev/null
+++ b/dev-python/graphql-core/graphql-core-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="GraphQL for Python"
+HOMEPAGE="https://github.com/graphql-python/graphql-core"
+SRC_URI="https://github.com/graphql-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/promises-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Rx-1.6.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+# Add these to test when we have them in the tree
+# test? (
+# =dev-python/pytest-3.0.2
+# =dev-python/pytest-django-2.9.1
+# =dev-python/pytest-cov-2.3.1
+# dev-python/coveralls
+# =dev-python/gevent-1.1-rc1
+# =dev-python/pytest-benchmark-3.0.0
+# =dev-python/pytest-mock-1.2
+# )