summaryrefslogtreecommitdiff
path: root/dev-python/graph-tool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/graph-tool
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/Manifest6
-rw-r--r--dev-python/graph-tool/graph-tool-2.35.ebuild (renamed from dev-python/graph-tool/graph-tool-2.29.ebuild)13
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild13
3 files changed, 21 insertions, 11 deletions
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index 4f7590542799..eb1a8184f9a9 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1,4 +1,4 @@
-DIST graph-tool-2.29.tar.bz2 15068583 BLAKE2B 28eb191d0f9c049eb5e5cd70ff30508bc6347566e757f11dc21cc7775c40ee1a86490516f6616e0dc7086983e510785c695db4ace64aa2c83b67c3ca1f534ad6 SHA512 f7a40f0ff5cb5ce3fdf39cf38744a91f7936e8d1dc487f0428c9f29893ad9d5163d5b76d7c07e3651ecb7035bea4166ca8e169934be54247f3285f4e0fe7269a
-EBUILD graph-tool-2.29.ebuild 1752 BLAKE2B 04ff30a44486c2391264d6ce714e6b011d78497aefff87c535a4571edf9d541e9c919ea8929c87918115e6b03fa3b089187a9f9481eda9da59d21a2ae19a3a82 SHA512 aded5c8318ae872d7ec2bad39503769c2be3f5f758c08f6128b223d73ce7002bf852d7a333be81a4ffe9b05f8004f91cdbce718e80dded21e91586458097f91c
-EBUILD graph-tool-9999.ebuild 1752 BLAKE2B 04ff30a44486c2391264d6ce714e6b011d78497aefff87c535a4571edf9d541e9c919ea8929c87918115e6b03fa3b089187a9f9481eda9da59d21a2ae19a3a82 SHA512 aded5c8318ae872d7ec2bad39503769c2be3f5f758c08f6128b223d73ce7002bf852d7a333be81a4ffe9b05f8004f91cdbce718e80dded21e91586458097f91c
+DIST graph-tool-2.35.tar.bz2 15153787 BLAKE2B 31f815f564510bb9628f43e8afab1a561222d23aabc3417ce474f0db69625954fc46119f61e8d7764d49a291e16e3b32f2e4249304f934c08d17af3e47a39ce8 SHA512 eadb122b75ff95fde165bfe1be8387deb08b48d041236aff11a0b8414d1a5027931a5e4b3216348edb61c53187b191a5e78af4eabb1ce679dd8736651f142bec
+EBUILD graph-tool-2.35.ebuild 1815 BLAKE2B 2c16de329fa4832c3d5145bbbc4fb95ebc2ec84578d58f96c1c8db24a4fb1ccac9664414a7e0a4f950c17234888ca9078773a43b037223f5933c013649d33272 SHA512 fd4d95f3a1c1537733cbd3abe8f3ef832f3d3b25ef865821d1b20ed5be7f5e0e5b0209eb65dcaee012b6e9c8d3b9f7c6ef6996204d6d169d0a84838fb2112bf8
+EBUILD graph-tool-9999.ebuild 1815 BLAKE2B 2c16de329fa4832c3d5145bbbc4fb95ebc2ec84578d58f96c1c8db24a4fb1ccac9664414a7e0a4f950c17234888ca9078773a43b037223f5933c013649d33272 SHA512 fd4d95f3a1c1537733cbd3abe8f3ef832f3d3b25ef865821d1b20ed5be7f5e0e5b0209eb65dcaee012b6e9c8d3b9f7c6ef6996204d6d169d0a84838fb2112bf8
MISC metadata.xml 346 BLAKE2B 69ef980447280fb170c6fc3d23bd775afb2cbc451054214ab0d1628ac5ac4be136a796c1f367d9e5ed2b914627cfe246372fba4f59e810469439b5e160d8aefa SHA512 1f8d51beb2a99ff4ac06f8e13529f09f4ed7322ed05ca281fc2e79d8cf309e3ef38695c57d27f80f25a490edb98ae4660b16fd3f671f232a3e1be2daf253ac7a
diff --git a/dev-python/graph-tool/graph-tool-2.29.ebuild b/dev-python/graph-tool/graph-tool-2.35.ebuild
index 90b94419f20b..20fbfe4e5570 100644
--- a/dev-python/graph-tool/graph-tool-2.29.ebuild
+++ b/dev-python/graph-tool/graph-tool-2.35.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit check-reqs python-r1 toolchain-funcs
@@ -28,7 +28,7 @@ RDEPEND="
>=dev-libs/boost-1.70:=[context,python,${PYTHON_USEDEP}]
dev-libs/expat:=
dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
sci-mathematics/cgal:=
cairo? (
dev-cpp/cairomm
@@ -74,6 +74,11 @@ src_compile() {
}
src_install() {
- python_foreach_impl run_in_build_dir default
- find "${D}" -name '*.la' -delete || die
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index 90b94419f20b..20fbfe4e5570 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit check-reqs python-r1 toolchain-funcs
@@ -28,7 +28,7 @@ RDEPEND="
>=dev-libs/boost-1.70:=[context,python,${PYTHON_USEDEP}]
dev-libs/expat:=
dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
sci-mathematics/cgal:=
cairo? (
dev-cpp/cairomm
@@ -74,6 +74,11 @@ src_compile() {
}
src_install() {
- python_foreach_impl run_in_build_dir default
- find "${D}" -name '*.la' -delete || die
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+
+ find "${ED}" -name '*.la' -delete || die
}