summaryrefslogtreecommitdiff
path: root/dev-python/gpep517
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/gpep517
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest3
-rw-r--r--dev-python/gpep517/gpep517-1.ebuild44
-rw-r--r--dev-python/gpep517/metadata.xml13
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
new file mode 100644
index 000000000000..2904f7bb62a2
--- /dev/null
+++ b/dev-python/gpep517/Manifest
@@ -0,0 +1,3 @@
+DIST gpep517-1.gh.tar.gz 6871 BLAKE2B a298a445cb24dbc708985ebe0be266ed6549525a2b9d250ddb53129502f04a442927ca4c29445f4caf4ada82e106e5498c9586e78dd8a4bd676c7aff747544b6 SHA512 83ccf6124e388aefcdece391d12daf6a337d52b7bb794268effd2abc9bdab6b00d935d01cac774b4a66704578160e44617b16a5b8b9ef821012d419848145e9c
+EBUILD gpep517-1.ebuild 942 BLAKE2B e660a9ef46d43a7f785322dd4f721bc2781408eab83900d9686e9301f211fd9d627a4f3f2505663ba5de5ccd14f864b1fb38d28eedf5893cd19cc35d05ad1592 SHA512 e34237abbcf1869a388eae98636858d0dcee35103aaa8eb714450b7da0989bf5f302067616681902f4d88f666da0a16c19b7213bbe36508ec2c99461171f09ed
+MISC metadata.xml 396 BLAKE2B a3f6d1cea383a38b4b6e5f80d2306ca320a66c0d3b0131601ef6f0ea48483757b9123d74ba99fe972dde06a998c15290cbc4243285c240493ae0293d2f8e1141 SHA512 8c584869f2fc7a0947b9e5ffa330652d8b6e61a6a472fcddf0422f1719422fb8d477cdf17d87e6d0e9f6994d608a77202c24e531dd146b0f8d731a047f80d14e
diff --git a/dev-python/gpep517/gpep517-1.ebuild b/dev-python/gpep517/gpep517-1.ebuild
new file mode 100644
index 000000000000..0fbf09a24da9
--- /dev/null
+++ b/dev-python/gpep517/gpep517-1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/mgorny/gpep517/
+"
+SRC_URI="
+ https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}
diff --git a/dev-python/gpep517/metadata.xml b/dev-python/gpep517/metadata.xml
new file mode 100644
index 000000000000..802f821d7abc
--- /dev/null
+++ b/dev-python/gpep517/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">mgorny/gpep517</remote-id>
+ <remote-id type="pypi">gpep517</remote-id>
+ </upstream>
+</pkgmetadata>