summaryrefslogtreecommitdiff
path: root/dev-python/googleapis-common-protos
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
commit7b02e37a04e4051a91a109814d386711f41f9a4b (patch)
treed0689f14f1d1df3a6a2525512a6812b146064a9e /dev-python/googleapis-common-protos
parent5c0c70d5917e66743293789a6d6fd7d72250eb32 (diff)
gentoo auto-resync : 13:07:2022 - 13:36:46
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/Manifest2
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.56.4.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index 18ef8baf1237..4e6c91c48238 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1,5 +1,7 @@
DIST googleapis-common-protos-1.56.2.tar.gz 109718 BLAKE2B 6aeb43927f5c2b0332dbc478d47b06d49490b666158b35b5e58ccd3290939d903865f60ff11f396f9f329bb64382aa636d87ebd06cefcb66d465a0551843178f SHA512 814dddc95fa5bde437c124ff8b66c281f98cae6c0143d473b9194a1367ccaf7915c21450f79f372be5fdb3c4fb41c9d717e57244f2dbd1e819b927b8d86e8d2f
DIST googleapis-common-protos-1.56.3.tar.gz 109601 BLAKE2B ac33ad2d9c737962bbc8c505ce03f57c9add2c9e9d7909371bac33651209bda8a6f85d00d9d93ca8f5bca5a88a3d148c6b0da210dd8330b2711cf3de027a307f SHA512 258f5408c3aae884ddcb13a606f369e80f56675296edb4fdfae1633bfdc707cae414920f87c21e210940667ede2989de7d80355a4b6551f5a9fc567a99fb64c6
+DIST googleapis-common-protos-1.56.4.tar.gz 109551 BLAKE2B 14886a639258c62442f1bd33959f303f280728584d1d2cb2c0f9666b1fd645b9166eea3c149d3081a36ca61b7c48ef0677760d0078f6c46f6c9ce3338d0664b6 SHA512 c4dc3d5390caf5b671b5cf091410d660a96e5e5df5b9584cc757cc5c6929dabd8456965a7721a7573fa28ba8143af8f4c30183193f2e735eb1e25b66b1e15d7c
EBUILD googleapis-common-protos-1.56.2.ebuild 821 BLAKE2B 3692f07bb33fe1831f444290716690ce77bd7e9a0bacb745e5c2c9ed64c19bb190cce3e803d11d78e4b8959b1f6bc17eff83723c6ccae9af4b05dc1e2f07c7f8 SHA512 651a2b8fe712bcb4e48576dcabdfffde7343391f05cab80717f6b61c9b166aff107943cba085f7863c0ff5a249db676dfb230d8e857879c49e570dac444a1323
EBUILD googleapis-common-protos-1.56.3.ebuild 823 BLAKE2B eb1a446f4779f4677c8b493b970ba178cb023d351013a8690c63a2e66eefe606146e8420616e4683ad3aacb4c788d7716288d90f0dede7909b8a516795d3aee6 SHA512 29aaf95b88310c3cad592abaf27473cec869ad7dc085264178cb6882c461346ea7b79599fd71860d1f4ea5ae85997c2ce440a379c89a23f678dc1680cd7fe0ad
+EBUILD googleapis-common-protos-1.56.4.ebuild 823 BLAKE2B eb1a446f4779f4677c8b493b970ba178cb023d351013a8690c63a2e66eefe606146e8420616e4683ad3aacb4c788d7716288d90f0dede7909b8a516795d3aee6 SHA512 29aaf95b88310c3cad592abaf27473cec869ad7dc085264178cb6882c461346ea7b79599fd71860d1f4ea5ae85997c2ce440a379c89a23f678dc1680cd7fe0ad
MISC metadata.xml 537 BLAKE2B 7b81f41f34a3c0fa53340ad298440f67727eb1830009899ffa10835485f66e727844735a88bed94b8a0bba14fa01a78d8a04f5ca3edf48a72781c7e1a797459e SHA512 6013da3540915e13a0cc60336bbefada12fbf71c04d4f40634f24015ada732d0d8b86600401bdadb2c7df2ea84f7097669f4efe6cf176ccca5efe46e9a3869d9
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.4.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.4.ebuild
new file mode 100644
index 000000000000..00d26d4c7744
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-4[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code