summaryrefslogtreecommitdiff
path: root/dev-python/googleapis-common-protos
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
commit1e3939094253168dfdada63e645d674cad69260e (patch)
treeac694a92b15d94d2e7544b8591123b7b04cf11e9 /dev-python/googleapis-common-protos
parentc98eb096c37a4252dc388920f0b0f8b2441c9b5d (diff)
gentoo auto-resync : 16:11:2022 - 18:55:17
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/Manifest2
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.57.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index 89f01d17ecf1..d7ebaea5a3f4 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1,3 +1,5 @@
DIST googleapis-common-protos-1.56.4.tar.gz 109551 BLAKE2B 14886a639258c62442f1bd33959f303f280728584d1d2cb2c0f9666b1fd645b9166eea3c149d3081a36ca61b7c48ef0677760d0078f6c46f6c9ce3338d0664b6 SHA512 c4dc3d5390caf5b671b5cf091410d660a96e5e5df5b9584cc757cc5c6929dabd8456965a7721a7573fa28ba8143af8f4c30183193f2e735eb1e25b66b1e15d7c
+DIST googleapis-common-protos-1.57.0.tar.gz 115316 BLAKE2B 3514774e537940a06db788646efcb9fbadbd5c0014844eaabcd4f24810cb13f8fc6983b4d451b5d5d3c8188e07548d60a42de9faebc0b6a8d883d61314405e04 SHA512 254f31631508770754a3bcc72a31705fc80aca87186291db73c20dd85ee209c71d97110dc2c9c742243ccb2121d38d77d3e1dc8a05eb4fc77ce07a2f32f7ef31
EBUILD googleapis-common-protos-1.56.4-r1.ebuild 821 BLAKE2B 1820b5496396cd0222446e5908b69d6fb193e8f1def92cfd17ad702ce77d7e30a1d5e6d64acd9585d31c6766640cd861818b4003da96b93218ee5214e7a002b9 SHA512 3bde73fb7cd6910648382b920649d80782734e120639f7ae0030e05fc4d6653039becf54f0ff9ea150eb108e32b61882828d77cbfd079ef36590c7cbc5c10b24
+EBUILD googleapis-common-protos-1.57.0.ebuild 823 BLAKE2B 5f513d4de69e439f1bd156dd9b19bc2446374b38e68635e88bfd699978dc3cfd4efcbca771af2ed3767ba70d72da774091ac4bbb7db797b3fbd1dc81fb37fdac SHA512 59078f93185c6b5c5e4a91df476739138e5a3e6317f42872b5c6d41bd0e3e167e760e4b8dc540ef9b8ba4c2485a91f2d1562e52826e276e54e3c6b03277748dd
MISC metadata.xml 537 BLAKE2B 7b81f41f34a3c0fa53340ad298440f67727eb1830009899ffa10835485f66e727844735a88bed94b8a0bba14fa01a78d8a04f5ca3edf48a72781c7e1a797459e SHA512 6013da3540915e13a0cc60336bbefada12fbf71c04d4f40634f24015ada732d0d8b86600401bdadb2c7df2ea84f7097669f4efe6cf176ccca5efe46e9a3869d9
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.57.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.57.0.ebuild
new file mode 100644
index 000000000000..adbf1c2167d0
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.57.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code