summaryrefslogtreecommitdiff
path: root/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
commit9d1e33edaf09cde926d589461f40e378d4124be9 (patch)
treeb0a5a85acd92ce912a95245121dde9cebcf76b71 /dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
parentdafa6f367240d1f5329ca89fb6f78985dbdc025b (diff)
gentoo auto-resync : 05:06:2024 - 00:07:52
Diffstat (limited to 'dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild')
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
new file mode 100644
index 000000000000..0848eb13e75e
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.63.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code