summaryrefslogtreecommitdiff
path: root/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild')
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
new file mode 100644
index 000000000000..e33bff07b4b9
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="https://pypi.org/project/googleapis-common-protos/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code