summaryrefslogtreecommitdiff
path: root/dev-python/google-reauth-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /dev-python/google-reauth-python
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'dev-python/google-reauth-python')
-rw-r--r--dev-python/google-reauth-python/Manifest3
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild45
-rw-r--r--dev-python/google-reauth-python/metadata.xml12
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-reauth-python/Manifest b/dev-python/google-reauth-python/Manifest
new file mode 100644
index 000000000000..cb6b6800594b
--- /dev/null
+++ b/dev-python/google-reauth-python/Manifest
@@ -0,0 +1,3 @@
+DIST google-reauth-python-0.1.0.tar.gz 17720 BLAKE2B c78a43f1062988ada715c9e1bb64c2252a3debd5b9b366df9780200717a006c5e4957bf37d81e645989c6fc74c5e5b4354c88244309bb1a22a936ef74f6172c8 SHA512 b92b822b5c59d74f7ac747e66f35eaa906a0e18ccbb791e0904551c6ecd9b904ac7602ea38333a16396ffa49638a1b4991827429c7f52311b9506f55400bf117
+EBUILD google-reauth-python-0.1.0.ebuild 1107 BLAKE2B 7fefe3c8e09ba68bafd42e57f41c744e5555d4fd56afffe6e8aff28579353842c7e8333d520e73300a16c861913682cd45bdd27e00c523fe94acd80dc1601d31 SHA512 cbfceecd3d8c58000e9d3db764eb89c90ca4c0fc768499c420100319bae389d3feb8078070f7f1104cc25af9b16ff98c1f70f29e9da36f056b1aa6d6bc8115ca
+MISC metadata.xml 387 BLAKE2B 3c273fa005cf2d68f977f8556723ae4577d05998471f3cd845f7335c84c610d4d4af9c971b6ee2edcf51b621e24eaf2083c20dabad714111b2d21cc99116d376 SHA512 7fcd5ff43d0f70d110f62c197f5e8f4ed6bf3192c457402c0d4bfdda66f32ba5144008d07e87d1661289ffaf1f2b637f7467dc1a50b65cf6606c17caf283b96a
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild
new file mode 100644
index 000000000000..5bdf90cc789a
--- /dev/null
+++ b/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based U2F host library"
+HOMEPAGE="https://github.com/google/google-reauth-python"
+SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
+
+python_prepare_all() {
+ sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
+ -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
+ -i tests/test_reauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/google-reauth-python/metadata.xml b/dev-python/google-reauth-python/metadata.xml
new file mode 100644
index 000000000000..babc9a183536
--- /dev/null
+++ b/dev-python/google-reauth-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">google-reauth</remote-id>
+ <remote-id type="github">google/google-reauth-python</remote-id>
+ </upstream>
+</pkgmetadata>