summaryrefslogtreecommitdiff
path: root/dev-python/google-reauth-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/google-reauth-python
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/google-reauth-python')
-rw-r--r--dev-python/google-reauth-python/Manifest2
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-reauth-python/Manifest b/dev-python/google-reauth-python/Manifest
index f12a293e4c8e..82e1b0c5e5cb 100644
--- a/dev-python/google-reauth-python/Manifest
+++ b/dev-python/google-reauth-python/Manifest
@@ -1,3 +1,5 @@
DIST google-reauth-python-0.1.0.tar.gz 17720 BLAKE2B c78a43f1062988ada715c9e1bb64c2252a3debd5b9b366df9780200717a006c5e4957bf37d81e645989c6fc74c5e5b4354c88244309bb1a22a936ef74f6172c8 SHA512 b92b822b5c59d74f7ac747e66f35eaa906a0e18ccbb791e0904551c6ecd9b904ac7602ea38333a16396ffa49638a1b4991827429c7f52311b9506f55400bf117
+DIST google-reauth-python-0.1.1.tar.gz 18302 BLAKE2B a21e174f7dffe48810679910bf8d6712fb4176e5608f2a068d575df3643c4db15a74dae92c15f4ffdc344d287c31a8eb58f94b0384e2d9fc808c072dc8f89043 SHA512 81705d4080b3d7fb0a73741f9f498f8014ec94aa165a5b112c8af8fddc8f040dc43809aff6df39354c8d975db0ee8d62d003c11b173bd56fcf9add1b01644930
EBUILD google-reauth-python-0.1.0-r1.ebuild 1072 BLAKE2B 597b29f6bde4d224be9d9b7a42ebe784fe953bfe042c2dfba954fd53c6d7c7cbeb1b55f0a7ce62096d6cda14584a075f73fc30facff18e838be00dca1fe7f8f7 SHA512 0818ee2d31373f2e6bbe8d58064653c4a38ae18920431394637d68acb1874ba9036986ecd26af24e3073bc9a4bd4a3656539c054f44218ab0426dde1ea8e0206
+EBUILD google-reauth-python-0.1.1.ebuild 1083 BLAKE2B 3cb3b322ac286f50c2962d6bcc29ffd036753b0a4aa932990834ca6c64c89ba478aed20ebdc308d2614cc89e277b2c85ce43c6b863f9ff4b4736cfde96c4e0aa SHA512 1868081cc00f617e0d012357a3ee61a5ab5ddc528da1dd4f7cd5b67a82c5a371c4762409488ee854387952bf942c88be919f276439acf195671517f9c90aa62d
MISC metadata.xml 387 BLAKE2B 3c273fa005cf2d68f977f8556723ae4577d05998471f3cd845f7335c84c610d4d4af9c971b6ee2edcf51b621e24eaf2083c20dabad714111b2d21cc99116d376 SHA512 7fcd5ff43d0f70d110f62c197f5e8f4ed6bf3192c457402c0d4bfdda66f32ba5144008d07e87d1661289ffaf1f2b637f7467dc1a50b65cf6606c17caf283b96a
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild
new file mode 100644
index 000000000000..ae794b24b60f
--- /dev/null
+++ b/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based U2F host library"
+HOMEPAGE="https://github.com/google/google-reauth-python"
+SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/oauth2client-2.0.0[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
+ -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
+ -i tests/test_reauth.py || die
+
+ distutils-r1_python_prepare_all
+}