summaryrefslogtreecommitdiff
path: root/dev-python/google-pasta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 00:56:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 00:56:11 +0000
commita2014cddc474ddf247d63fa74aac9a182a2bcefc (patch)
treef4a72c4d2dbe2dce9b029570659db8c778fd5877 /dev-python/google-pasta
parenta0a719bf17efc5be8bd5caa7abb9d2b199ea8231 (diff)
gentoo auto-resync : 24:01:2023 - 00:56:11
Diffstat (limited to 'dev-python/google-pasta')
-rw-r--r--dev-python/google-pasta/Manifest1
-rw-r--r--dev-python/google-pasta/google-pasta-0.2.0-r2.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/google-pasta/Manifest b/dev-python/google-pasta/Manifest
index db516f5a8caa..b30c9f62bf93 100644
--- a/dev-python/google-pasta/Manifest
+++ b/dev-python/google-pasta/Manifest
@@ -1,3 +1,4 @@
DIST google-pasta-0.2.0.tar.gz 40430 BLAKE2B b3f068c0530149d6e8057a2e7edeb76b1912516a8227a837913783060e30f418159b38c77480248dc7a1586b46c9b5914e93c77a9430d963b3538e2197661922 SHA512 1d75d994a5120109677a58472459a632b31568e6ce79b205688913dc2a94e132fad818c73510b2f7d7adca3c757077543abd8b7f15be035a63fa15d38874c753
EBUILD google-pasta-0.2.0-r1.ebuild 446 BLAKE2B 0fc61f93b471b059d0fd0a1586cd372ca76aa09f87d49aea3493c1445b2eb050658cc85811ec3fdc95348c5337a786eda52cec64843ba74de7d0b575549059d8 SHA512 228f262b0708b7d5256d470f8be7516e818b9b10a7830ded22c6c1004790bd6bf48604669e6042e7c0a89cb602bbfacaa190b29a384b75c941d99f3c776d72a7
+EBUILD google-pasta-0.2.0-r2.ebuild 478 BLAKE2B 31bdf6d3223941935e59ca130fbfdf36bb68b670653371caa60b46f90ffb835c018292e4cbe21a4be00ea89077629084ccc754e5e584e35ff32272f165a9b600 SHA512 11eb36781e101681413f46f749f5596a22bd69c84f0ed3d0f4012a26c538f8aa6cb7642e8cf8527a59b006ee09c25779117e9b44603e22e0e79a862c52e8cc03
MISC metadata.xml 399 BLAKE2B f844e211efde5a2f65551431341e95da42efc481b12c88cd549f75e7a050409b67d931b9610556acb0bcce41fa1b387fbda690bac8d5369bf93284f376e9a4c1 SHA512 63aa92d0c3184025d83858ad189cd21a68b9c77e25f9a6b192da538400739e8b9f495db3a18c35273c83c47d957cc15ad6cec24f447ee279181de68843c10cfd
diff --git a/dev-python/google-pasta/google-pasta-0.2.0-r2.ebuild b/dev-python/google-pasta/google-pasta-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..c76100e7e0a1
--- /dev/null
+++ b/dev-python/google-pasta/google-pasta-0.2.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pypi.org/project/google-pasta/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest