summaryrefslogtreecommitdiff
path: root/dev-python/google-i18n-address
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
commitb9e8f3cc44aed3b6da71c7510c6287bf7bbbc66b (patch)
tree4b47f3026f10252cff69e7a4346215a4da4f0f1c /dev-python/google-i18n-address
parent3d952d0bfe7b386699eb32d1431deb0c538f044d (diff)
gentoo auto-resync : 14:06:2023 - 15:13:45
Diffstat (limited to 'dev-python/google-i18n-address')
-rw-r--r--dev-python/google-i18n-address/Manifest2
-rw-r--r--dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/google-i18n-address/Manifest b/dev-python/google-i18n-address/Manifest
index 069e8d5fa2d0..6d5d02fce5e2 100644
--- a/dev-python/google-i18n-address/Manifest
+++ b/dev-python/google-i18n-address/Manifest
@@ -1,3 +1,5 @@
DIST google-i18n-address-2.5.2.gh.tar.gz 724067 BLAKE2B 1ec13e99216e263985d04ceb3efd6708041a91be2cc6d4531c099d1599bfa55e21ebbc785d94bda245304bc904778e906c036b2bf0235c9e7c26c8439a69ad07 SHA512 3e9a583cee35af2c045c41fbdafea8dab2897354422a4d2df96834d56443499442a62fb19be42d06cd8974fac677936cb34713730b1c3c18c9a041a7ae46c5cb
+DIST google-i18n-address-3.1.0.gh.tar.gz 726728 BLAKE2B ef41b285aecea0b3e11b08c0815d57a2c3816c59fe01fab64fd75913b0f870e42fbcd0ed76b201c6cd47e4b249c03689b54c648468c3a2cf3d3cb67e2be7ab03 SHA512 b47b5eeaf214a04614ed0976055d25fbce2d298c45db4bfe31b369cd27dc1e097b14d4fae62b5f8dd95be5693d2fda12d0b618029dc1f3ed2784e28b60c43ef9
EBUILD google-i18n-address-2.5.2.ebuild 627 BLAKE2B 5a92e668e2a3260d7774f451e14c9356e228a37c8230f5296fe3b066e7fff9a937b5d692e584cc51734a55d7469d3b4daab62eb237d1d9ce619e599fa42ca007 SHA512 cc7951fd854c116364abcdd54df64a5c3cfccf3d84fccac719dbc604b36f332197797a767b9ae8e84394e710f0d31d02d917037ed468628f5628e63a82561acf
+EBUILD google-i18n-address-3.1.0.ebuild 627 BLAKE2B 53a56b925f1f665105de65d413883471a0eda275cda28c88675daa6f560e25796e382dd25aabc5280203850f87c03d8a6bd9f74b3f57abe45a03bed395f45415 SHA512 af9f3417a7b7b4612d0b8c1349903ba056d879d0ec191b6b8b7209744c80cb9bad6c6a973b6a2215b4911edde0f448c048c57d08541c3bb4e54b0ba20e1319f9
MISC metadata.xml 498 BLAKE2B 0a06e46935f90688ffec111afb963e29f192847f1511fb81cfcc2588076bf8d2e335bf7a8138da44fd9452b0f13c6496762682695bf5dbddc615d91656bd3322 SHA512 5f4ffa9b5247d8be2352ec3e9e325fb24c50a7f341f78e3a0a81c51c76dd46d3c1922954f27606a6720a9d3cbf330c556a56bf35d824e27b151b8174387df48f
diff --git a/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild b/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
new file mode 100644
index 000000000000..514b69a1c503
--- /dev/null
+++ b/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's i18n address metadata repository"
+HOMEPAGE="
+ https://github.com/mirumee/google-i18n-address/
+ https://pypi.org/project/google-i18n-address/
+"
+# Using the github release, as it contains the tests (unlike the pypi artifact).
+SRC_URI="
+ https://github.com/mirumee/google-i18n-address/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest