summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
commitfceeb864f5e0e6155b3f5ed010298e5b7b2f1278 (patch)
treeeae9568ab98ccfbd977dade72fecdd45c670fc9d /dev-python/google-auth
parent517343fddd94e620e94be97ae22eca4b57dc7625 (diff)
gentoo auto-resync : 18:02:2023 - 08:10:15
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.16.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 34f860452b75..f1ca68828dd8 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-2.16.0.tar.gz 223336 BLAKE2B 9dbd54bdf072dacdf728f6fc34931f153dd409e3e1b92e37ed652a1db39d5380b7e66bd196cb1192f75234b2317518a443f8f515bc9135f553e6c9f1116fc606 SHA512 dbeff00089a410c6702e2bd704968c7392809dc217b3f511b62429a11649e4b0607a41622d2753bed9e511368b1c32086b23df66ec915e07a1dd4f32471e025d
+DIST google-auth-2.16.1.tar.gz 221594 BLAKE2B d220bbd22e560f291566ed533c8f3f8961f611bb65410b2ed56a9d9745f1a269a46df7f9075565958a919266450e1702c808eb4fc12680b74790983f8897713a SHA512 87e648832cd88d789334e59ea05545dd567ff7cf5d65d5dd2c209277716b6a77e92e082e9db91df208f1372a010ef1d6830ff77dbdf77d0fda2b649da39bcdd9
EBUILD google-auth-2.16.0.ebuild 1526 BLAKE2B f9b3a2c88eff61debb3027b55a995c2b854f07b7ae1f91b27807d7278a006d7e14b592be18d901b2709e14c6d7c593a76a4e9d74604287d511c55f4852122dfa SHA512 403cbbaec7ca6a52ba6ddcae159921ec4eb10505fc70288f7fd9d7536cd40b5ff0ed78202d2ed153358d84c59f3641c87815121a17c2cd30a842028f28ad6bea
+EBUILD google-auth-2.16.1.ebuild 1501 BLAKE2B 46f8dffe0cca47cd3ee6d1fa1a3820581bafe73e49f1657eb4aece8dbe864e816f90ce441ce6c2280b1a10642d331601228e03fa98d3964a5188145809574d58 SHA512 7f2bc0d018beeb51147ecaf324c53f923a84a416eb3dd8df9c05bdd654b8ea96360ece5f3048d4aa6280f8ae2786d884817fc38dc3cfd4d8e603277c81147d61
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.16.1.ebuild b/dev-python/google-auth/google-auth-2.16.1.ebuild
new file mode 100644
index 000000000000..5faba10d7363
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.16.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}