summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
commitf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (patch)
tree6296aa82e3fe61664c80ba6cdd0d7cc410a1c2ad /dev-python/google-auth
parent80422eacf48ea819f1aeefc7a809533aa63fb85a (diff)
gentoo auto-resync : 29:03:2023 - 09:53:01
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.17.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index c13c80b0ef14..bb11529eb9cc 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-2.16.2.tar.gz 221392 BLAKE2B 858ec2d01b7c8e573ddc310a17d634bd63032f469eb47b0fe5fd3c4bcdb5e3388380fba671958734e1b406ff19c9f8d5b70d8e25587e2e813e1300b27329dab4 SHA512 5686846fbd299e8d331a2132a1f2847febb68f06e460aed987ff12efa3a629c274f6b9dcae53b8b3d9075bb590e5e265eb11b9d6eb3861d4230f91f0bfea84f1
DIST google-auth-2.16.3.tar.gz 221824 BLAKE2B 759b450936e7675b1c50ef574b8e9877d4b086a9e77b47958d56743fe140790359a79de026bc634752aa0eb631abc8a50da4804151071217af34fba588b72c01 SHA512 4010e19cb079baa32ad93f3ee6e9bc142b6edd331247251a14ee8ef9be166d81032cf10a6e000edc32d59e619021c4c9e500658288e4941a886d1d99e86ab68c
+DIST google-auth-2.17.0.tar.gz 222518 BLAKE2B 3f639cb000303c44508599e453385363ae70d01c5c359eb9c82d0882cb1669ab4b02b6acf5cb2bacaae5fdcebfe8244bd537836d58eb5f34ef66a933b50b7ff6 SHA512 2942f385febf8d2a3f3827e048646e01c06ac3c2880ebb06d5a6eaeeb3d258cbd5ba7d969c7aee00a74332b5ce9b43a9474daa9e2e1de72bfb5f97dfb8065b96
EBUILD google-auth-2.16.2.ebuild 1499 BLAKE2B cee30a1d99552267a90dd4a65f98ef50b7eabbb2cf0b9ededdbf1699d6ad5cd2a1ed4f7cfd3ce0fe9b07ed21313c79ce31b64882ecfe6d8617e6d2cdd379836d SHA512 7615ac631b13b2fac5ac41fa99aaea5a7bb3929994f0d1823c7753e02b90997c02696ea0a271b3979c4f181fe0671c38f3b39de0b676f145d62d1295cbbe9f30
EBUILD google-auth-2.16.3.ebuild 1501 BLAKE2B 46f8dffe0cca47cd3ee6d1fa1a3820581bafe73e49f1657eb4aece8dbe864e816f90ce441ce6c2280b1a10642d331601228e03fa98d3964a5188145809574d58 SHA512 7f2bc0d018beeb51147ecaf324c53f923a84a416eb3dd8df9c05bdd654b8ea96360ece5f3048d4aa6280f8ae2786d884817fc38dc3cfd4d8e603277c81147d61
+EBUILD google-auth-2.17.0.ebuild 1501 BLAKE2B 46f8dffe0cca47cd3ee6d1fa1a3820581bafe73e49f1657eb4aece8dbe864e816f90ce441ce6c2280b1a10642d331601228e03fa98d3964a5188145809574d58 SHA512 7f2bc0d018beeb51147ecaf324c53f923a84a416eb3dd8df9c05bdd654b8ea96360ece5f3048d4aa6280f8ae2786d884817fc38dc3cfd4d8e603277c81147d61
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.17.0.ebuild b/dev-python/google-auth/google-auth-2.17.0.ebuild
new file mode 100644
index 000000000000..5faba10d7363
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.17.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}