summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
commitee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (patch)
treef4cdf4b4814dfa35e701a066e3bc3c50f6afd7cf /dev-python/google-auth
parentdbd6eaafcce6a59fa9b3323124c38fa17aa88e26 (diff)
gentoo auto-resync : 21:03:2024 - 01:00:11
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.29.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index d57f62b691b8..f4c167d8e2fa 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-2.28.1.tar.gz 240469 BLAKE2B 5bb74863eceddb7e0a1cdd6adb52a7467fcbd23a913177d20910194458721c3abcaa5d2f1f93324fae08aff91c8dc9fb65ba786ea8ed698daebb440505f17b2e SHA512 013c90dbeb6868406f56de87b72277a7932795ae3b806442bf07e90d34143e9a8035d2481f8c46a707a2bb0ed4285a1cb249613eff0da0b28b1aced783ce6a08
DIST google-auth-2.28.2.tar.gz 240450 BLAKE2B 8e82f3e27ca6eaf61c48acdb233437caaebd5c4bd59a0392c097b816a4efae74b492504608849afa85d58d32822943e245b355ac48d18bb1fb6807cc7278bdba SHA512 9aaef2034a1b85350a39662dfa2ab53fc4e6a46326ac5cf2e361b3f8febd196d2cf5e5ab01c1bb3fedf33f0e1526ed33db60b088ed6c943732a70ed65c7cba01
+DIST google-auth-2.29.0.tar.gz 244326 BLAKE2B 36b0bd8f445e3c7c3e0a83d07cf5924401dec99cdd22a6042bf5b9ca1cc9b1e28d0029f8f1509bcb32a7c54abd7c453dd5077ad25886d265822cf1c880b1326f SHA512 0f6d7e9728479a5937d72321f5ae6cfa3592dd42bb518a5519fc0936b533472e872fe947470a1774f8e53a2dad3c65e001de3899b74b6373dd149c6944423473
EBUILD google-auth-2.28.1.ebuild 1439 BLAKE2B 7f1d474e335a4a6ec0a86d6f47d69accd6ae97bb5ff53f1d1c4e8d78c79ffcbaf3f1a633a279936276ecf707cc2455f494a68a599c3299f06e73090e08d3b4c3 SHA512 cedc905deb31d47c3581d26b8b7765145452a281c0ca0ba79966b47d1f20779ab41e6c321b3ced80b7d805bd3d9ab47cdf041e3d0c727b69c88059b584e6b54a
EBUILD google-auth-2.28.2.ebuild 1442 BLAKE2B ecbc9be9f3ad790c4f3b52d359cd4e3727fb67c5b179a6a3da566077ad811ac6e7cf459af03fcfd088e8c61ba035780fb3f0f59f79be33f2699ad044a821af10 SHA512 dd25537915a25048d6baa439a9c983c432c334a7cc395eda312d2517c71f83750964cd4d1978886d270e3f6e38f020f75875ecfd86e9bd102a265e9c729bf812
+EBUILD google-auth-2.29.0.ebuild 1442 BLAKE2B ecbc9be9f3ad790c4f3b52d359cd4e3727fb67c5b179a6a3da566077ad811ac6e7cf459af03fcfd088e8c61ba035780fb3f0f59f79be33f2699ad044a821af10 SHA512 dd25537915a25048d6baa439a9c983c432c334a7cc395eda312d2517c71f83750964cd4d1978886d270e3f6e38f020f75875ecfd86e9bd102a265e9c729bf812
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.29.0.ebuild b/dev-python/google-auth/google-auth-2.29.0.ebuild
new file mode 100644
index 000000000000..e044a6c75ff3
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.29.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}