summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
commitddb6fbc11e863756a24e1dc866c63dec00eac6fa (patch)
tree697bafc13819641c0cb81d469945e2a773adca86 /dev-python/google-auth
parente466209c898f09389f2308d193286ff62b46c1dc (diff)
gentoo auto-resync : 27:09:2023 - 11:30:42
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.23.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index d3391a8f1ee1..e40018f9775b 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,6 +1,8 @@
AUX google-auth-2.20.0-urllib3-2.patch 2525 BLAKE2B fec791fcbe884b0d5a1da9603798217e44f58f8afe1fff660332b4aa4ba726630f9ca4b3de013e918cfe3a0756b2cb1311f6f6aa89cc8ef0af7c9fe3a3dd50d7 SHA512 2f8a6ebdbd66ee1c1d0f2449768239c702115ca91e86b29677093413b1d71844ae0ac8ea77669b94b0088898d639c72432851e02f992d3b782bb1fa0b02cac76
DIST google-auth-2.22.0.tar.gz 231433 BLAKE2B 07b813209ce3f5ff429c4f9417141fa85029ff3eedb116664d6effdf508497ce6b6552fa4c3b6f9f1e7f1ffe9b9ae8ce72c8c727d277662bb9f8214ccd152b66 SHA512 c2c04e9ad367dd96bf00af7b19c7d897dd9fe3f8e9318b7436ec85a5c146b29c273cc718932956e97b2e4a1e2f12d0d10e835b6cf0f4e46ee19f6aaeed492b5e
DIST google-auth-2.23.0.tar.gz 231512 BLAKE2B fd7594fb28114d07773e2f0bf2da475cb1d771ef27f67765e9235883cd312b88cda092c5bcbb7a1468ded44da4e5cd121c58850058b023232725a9829969b8c3 SHA512 d5c4967478c2a2846f2297b8449cd1a9de9796f3e1a5075ac7a3c2c35a30468fe93bf5c37b7bb4305925fe5097a57fddbddc482be4446e4364a78709eec1d8cd
+DIST google-auth-2.23.1.tar.gz 232191 BLAKE2B ce828a3f04993cfd4746c096b70b5813e60acd8ed56ffc87f608f4a33a465eba4cc52a58906a7d5aeed787bf4b26b8f77fb02294181e61ed69f9036fce34dcb3 SHA512 2d8677cff7c3c6de70a4e6934a78585c098c2f2a8ca3007acb8eb4612b32ffd1ce9c841aa57f9ce043fab071dddf3bef153684541a82a80a5a914d7c377acb9b
EBUILD google-auth-2.22.0.ebuild 1636 BLAKE2B 184cd9afe0432f664ed53d96cbfd68277ab063c9f7ad7e2bce10840d80cfdb61fcc0475f677e2b94f1f1a6c8ed22967d3fda7537c7b1669042e1a9663332a2c4 SHA512 51c5edead6407ae45f7ca92efba32a0799b23201d2c9a475b9e4ab07ca84a6f77669aab892790481b9234721db62df6c2b39c3e74b2cd2121fb3ef4d0dc29d18
EBUILD google-auth-2.23.0.ebuild 1656 BLAKE2B e416ecf4a60bdf1a14b556a15f0655b771ac08357210341dcb307fa0dd9f3834d86d5bf2fdc57cd1c886a9d13dcb31338ee36796078541ee6013a1d7dacfdfd4 SHA512 0cf2306868c09b083735d28e5122038dce41eb8e8f3403e17baa2997dc31832fa3f676f646ba96925303381790ca4a2a84a7674cb852c97017925cce7728b241
+EBUILD google-auth-2.23.1.ebuild 1526 BLAKE2B ea5c968ab2fb0479143155141d70d7ec6f4eeb6bf2a115f18ff6ec03b4cc64db91b658ed4101ca75db756c3af5cb74ca3a5fe115043a34d345ce8d41f42c6f0e SHA512 2e7111b48c64eddf73ea67916aa883e1f9d126a5daab969227fd36577e3c3394c0c720933bedafa0b6c34242220d647f5aaa386cfdcc57a8a3c6c89ee75e9b1a
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.23.1.ebuild b/dev-python/google-auth/google-auth-2.23.1.ebuild
new file mode 100644
index 000000000000..4cd570591bdc
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.23.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-2.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}