summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/google-auth
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest4
-rw-r--r--dev-python/google-auth/google-auth-1.25.0.ebuild59
-rw-r--r--dev-python/google-auth/google-auth-1.26.1.ebuild59
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 45eee85ba89d..b07a3cdf8ab5 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,7 @@
DIST google-auth-1.24.0.tar.gz 120351 BLAKE2B b0a78ad87622bc806cce72847d5dad3844afe080ffbcd822575dab6208952806360bed4e8756133d5b4fe2755f6cbeeb239b8f51634dd3d4cede9346372b689a SHA512 3e678dd946eb6c3c865cd35df1480a96ed35cf14b973f2239c5213b223a6569b4a9642609ac51243af75c662a08bbf0518d8592db97af297cf67c52b83019e30
+DIST google-auth-1.25.0.tar.gz 121940 BLAKE2B 9c7346b134153321fe7116cc77bdcd0d07b2d4a5264d4a982f23a44458ba17c03ef8d204d2c6bd697561c11563bbff1d093ec4563700910ea3bbd9a063006005 SHA512 1c83f18904b646264263c8ba20c13bcc61572b9de397331564b1c2e65083a27e6393dd9435b03789136d2fc2b43750f784d21a3dc670a58cc4bade9de267f195
+DIST google-auth-1.26.1.tar.gz 121927 BLAKE2B a24a9c5bca8de234213e75673ba49ef6b82eb3c165f9c3af276b3c4cd47750c6d8a53e46084ae71c8eadf474ec8f53c6a2469fd91e7bdcc87f61bd46bbf9704d SHA512 632cdada9975311ab079022da79334f69ae703183bef395c3b04fc86192c23032b9925259ade7c115883659b10a403661f2d9a39f3b5262b964d0b9f2947567f
EBUILD google-auth-1.24.0.ebuild 1632 BLAKE2B 3a64c4915bfe8626f7c240b27704a77f7cafa3697f85922f6fc74f612390908d34814dad94ffb649e7298b8e93b833e4f71dc8153bd725643d09c6f7ba4b1171 SHA512 c32bd705495a1be9e276e9de185cfc4f498cc186f71f89d5396f10dc7a4b16b8cf139209cd00a4d74f43ba027bf251e58f3ec79744cf8b64290e305889b78cee
+EBUILD google-auth-1.25.0.ebuild 1634 BLAKE2B 4bb0f2cd679828176bbb5599afbef8de92b2b14b6de3570059ce9e6e69b84bd8a5759d189835ce31c29bd34fc69a2684dcf89b3df6697bf88b71f6f2d4a642a6 SHA512 b7220099a99c3a3caf55e7a06b2efc6872de9c949366e1cceb05d1fd4b776e3fd751f62c6057471c6c40450b1f1e03982889d9e2f5090215dbb6a1c2ed7d9384
+EBUILD google-auth-1.26.1.ebuild 1634 BLAKE2B 4bb0f2cd679828176bbb5599afbef8de92b2b14b6de3570059ce9e6e69b84bd8a5759d189835ce31c29bd34fc69a2684dcf89b3df6697bf88b71f6f2d4a642a6 SHA512 b7220099a99c3a3caf55e7a06b2efc6872de9c949366e1cceb05d1fd4b776e3fd751f62c6057471c6c40450b1f1e03982889d9e2f5090215dbb6a1c2ed7d9384
MISC metadata.xml 419 BLAKE2B d8a88d0022eb8d396a504bfc90741d9274cb0e0c7f816444ca70533c6c4c0aef8d74e59a65141515a8db8b6768f43618ebba5e997494670f4e05131c34f7e609 SHA512 222e76f72e487b126c2407764023f7b4861e286015ad1e8204bac13e5c7b036db3a7c71908068061c5536535f354a82e547685c29c614af891100b80a7bcca3e
diff --git a/dev-python/google-auth/google-auth-1.25.0.ebuild b/dev-python/google-auth/google-auth-1.25.0.ebuild
new file mode 100644
index 000000000000..61a646b39ce4
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.25.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/google-auth/google-auth-1.26.1.ebuild b/dev-python/google-auth/google-auth-1.26.1.ebuild
new file mode 100644
index 000000000000..61a646b39ce4
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.26.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}