summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-01 09:48:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-01 09:48:44 +0000
commit89e7211956082c276a5a7bd56153c337600969e1 (patch)
treef4b5b3fd4ad8e247e22943db6619c152aa5eb3f5 /dev-python/google-auth
parentd4ad8633bc8c3408481e882d717fce4985457d81 (diff)
gentoo auto-resync : 01:11:2023 - 09:48:44
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.23.4.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index ccc33871f07a..19feb9d74f80 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-2.23.2.tar.gz 232207 BLAKE2B 0de53f79bd908d7194253525de07075779ffc0ed33ef71e50004773ba85aee8e7392cd5cc87ad88b5f9ce90bc3eb19c0c094d0e76311d2cd93fb0bdb62ab2450 SHA512 d443b769e6ee7de6da14e31f8beb938aaf63edecafcbedda46b253bf0380dbd78a4508a0214f7a708a09c39d1d262cc93a290ec44e89fa05da7796828f33c1fd
DIST google-auth-2.23.3.tar.gz 232472 BLAKE2B aab7c55e6037751f578c9b9ec83c2efac10bd0e9d755b56ff21cba68ce71baaff73f4947b00da54b02e41742f718b854d1c2efb88bf8ba8cb582c2425afcb29f SHA512 a561c1359e520e82de6faf3e0d60f8c072b96231ee2db54bea59ad9fa5caa505f91ab5b1008f7a3ebecdfcd70fbddbcfb5c19dfad8b0fe1424558284757aeb4b
+DIST google-auth-2.23.4.tar.gz 233560 BLAKE2B 3d058c9c16af4f982aac7411b306eeace70f17d23b7043328c235bff5233e79360cc5a9ca24b06e33d318606acd331b33fef14c7574338f9ac3caee3088c4f35 SHA512 561cff5003f5b6e37a0ab4fa4c827646bb9b3fee3dc500214b88ec3fc7203022f487abaee315751fb7d90b4ed9a9d9d0ab6f3dc7d3336d9df9d4b45e6146bc2f
EBUILD google-auth-2.23.2.ebuild 1478 BLAKE2B 4bedb77f85b4b3f039a5beb4516b7649d88c63d241621c7dc645833cbb55dbad04a1bbf6c19549bd13ffcc19e43c0761976ef8dc3e94a8a62f62f7fdef73c750 SHA512 b612b318441930cc8d8ee6d0d14c2db301e0080cf0afaa5990e818ab0a44891314903789ab9fe2b1c573ec17400c2de3921b32ca01cd6298923a714d72209223
EBUILD google-auth-2.23.3.ebuild 1480 BLAKE2B 79680b9d542cdafceb202bf0e1f49d7c654957aa7f186e8bd61ad53dd11ce2ab0b431d7e66ae012485ebe334161d4d3a8513f1237356500aa338d580c42bfcd2 SHA512 e7a800bf2b76574ee015da9753edcd18f4a9a7cb2953ee43f2712a7ee0d1a8164d900a790a5787af106d057fa6c9e0b8686a7077b956f31e0a71386e162476d6
+EBUILD google-auth-2.23.4.ebuild 1480 BLAKE2B 79680b9d542cdafceb202bf0e1f49d7c654957aa7f186e8bd61ad53dd11ce2ab0b431d7e66ae012485ebe334161d4d3a8513f1237356500aa338d580c42bfcd2 SHA512 e7a800bf2b76574ee015da9753edcd18f4a9a7cb2953ee43f2712a7ee0d1a8164d900a790a5787af106d057fa6c9e0b8686a7077b956f31e0a71386e162476d6
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.23.4.ebuild b/dev-python/google-auth/google-auth-2.23.4.ebuild
new file mode 100644
index 000000000000..3136de42f585
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.23.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}