summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
commit8435c842b9e8fbb2bcc80397ab3aa655000459e2 (patch)
treeb74558e80643a8f074c501e8b4bf7f50f7155455 /dev-python/google-auth
parent5c5e9714c851027611cb726a76ebb8be6d48cbdc (diff)
gentoo auto-resync : 03:07:2024 - 08:05:42
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.31.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 4bcb2814c44d..e1290e01d9b7 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-2.30.0.tar.gz 251462 BLAKE2B 63deab7b36e79a590348f6e0cfa5c1c0e0715468d35dfcb0e7227932d4d543953668ec4c4b78a087ee1fc22a37bfbc913f07c428f02fa894d28228fae68d0942 SHA512 23ebaf17c12d745214405867661b85eb628dafbc06b87f101ad10d4c4ea8e2cea04a4c9b0c0037ba8f0d8cc12c2221bd4199613fe3c3e3987c72525cb94a5bd3
+DIST google-auth-2.31.0.tar.gz 252986 BLAKE2B 50e7554feadaa19644a2f41152d0d255729d19fbd9b6e1967233f9bfdb79968f45e2179effd73b0ab513b25255371b43aab946668aeb7155c827b536e4005afb SHA512 2a2eec2f3638ab855d20827068d64a9adb856d341fc70bdb6401813543f73631d998c38f8350e9ed2a85897b7f0ed7401fc973b066ee2b77ac7ff746dcd7315f
EBUILD google-auth-2.30.0.ebuild 1434 BLAKE2B c1488cdcb44a04d4a1c81159a7ffba29e03694e19fee921f157c02fe851e278db54757699a27c4b9c6d60e4479de58b26013090429aa6ea553ea2913b4c84831 SHA512 4b28cdd4a5091a0c2331dcea6f94aae2a487d672a8c02e80b9af61c92007a547f838c93c3a2c5362c11911d76abdfeb67bdaae205db1dab863f7b1ba88b6cb42
+EBUILD google-auth-2.31.0.ebuild 1437 BLAKE2B 90d5fd083e3cfb70a04ee5981b99a46b4d919f3656311be56e2af141062f75dfa5b53916b2a5b8bab1bd888f2fd7f8bcfbe1695dc9a26d7fd74c6727b37503c2 SHA512 ba1e381aeab08d6d3f6442c1d2abebbf98a8ef37fabc3665944c9dab496dd7137d3f42f68fca107558fed21bca7529aeaad1d73528ddaa6f95fc654c2b50f48c
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.31.0.ebuild b/dev-python/google-auth/google-auth-2.31.0.ebuild
new file mode 100644
index 000000000000..ada169c0bafc
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.31.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}