summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
commit5e0583283abb5e0f998830cea3f4f9785699b2ed (patch)
treec9999a88a0ae4409d0f85dc733d2b42181f94a53 /dev-python/google-auth
parentfa3c4c282d03b85eb600bae6ec57b619004feb5a (diff)
gentoo auto-resync : 04:01:2024 - 07:58:30
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.26.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index aca58ad14dda..693021260d23 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-2.25.2.tar.gz 235648 BLAKE2B 527dada4cff9139ef2b90874aafe085e7b92f4edecfa3dfb6cf26a40e8470f68451fdc88bf5a9ce92144b7448ee4a32a011069b62d6ee02d0885db1ceb319f22 SHA512 2f03dbe6664cfd7086da82154a8fbea6cb97f3f05992faa0fc11399248d645eafa0b63e4f45e248ff73de693c15050f3dfa7060b0f46c8b22919619d5ebb82e2
+DIST google-auth-2.26.1.tar.gz 238839 BLAKE2B 91f866d35a9a3c0faaa8305e0b4d28ce87c8c5cf7b1549d4b8cea6cda96efeda4909846fd50545774c8bb128a1b7b1b74bc79ffd9bd78c4ddf138d75829bedd8 SHA512 08593547cc447e10bc1a033f154f1f4e7a248250899ef2ea49aa818a2705d0df3aa01c4dc84b6f4eb1f51e08187c634d229c396d0f2615a987e7fcc2dec9010b
EBUILD google-auth-2.25.2.ebuild 1477 BLAKE2B 9a156c2e5af7b16648efe235670c5b24df704194647c63b288bd8a6784316357148c9bbc5c9dba4d0bce746218bb70695bcd4f469df5d7b28bd8deb8930de45a SHA512 d3d91b3213fb3183f6993b520ffeaf931d069449126c20b3870493e3d0330bf7f1e8dfa47f34b69035234095bc257e7b297aa3328cdfe4b6eb87e94d0ec7b903
+EBUILD google-auth-2.26.1.ebuild 1480 BLAKE2B 035c1a5387414332c6c3d6fe7db43b7facb3d4f49f48937d507cbe7ce23f8c18ee0e45f50a425ef6ed2fb25a3f733e03a42635481e0d3ffeedb02e60019c9905 SHA512 1c6be188aa259780fd15599cffcc4e2a24e85f2cc8759af033f9def8009ab5308c9d2bd730004c936a4c636650f592d88b34f8b177101ae1062e005c7422e1d0
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.26.1.ebuild b/dev-python/google-auth/google-auth-2.26.1.ebuild
new file mode 100644
index 000000000000..edb9a92d286a
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.26.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}