summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
commit511da2e8215301136bf13531af2329e9703addaf (patch)
treee5b21768118114c1882a1f772d0565fb3ba1801a /dev-python/google-auth
parentd095cf23cccb27f0f047472717fdf96bf857110d (diff)
gentoo auto-resync : 01:12:2023 - 11:06:48
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.24.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index c69a2b7bfe5d..9acc72f77d73 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-2.23.4.tar.gz 233560 BLAKE2B 3d058c9c16af4f982aac7411b306eeace70f17d23b7043328c235bff5233e79360cc5a9ca24b06e33d318606acd331b33fef14c7574338f9ac3caee3088c4f35 SHA512 561cff5003f5b6e37a0ab4fa4c827646bb9b3fee3dc500214b88ec3fc7203022f487abaee315751fb7d90b4ed9a9d9d0ab6f3dc7d3336d9df9d4b45e6146bc2f
+DIST google-auth-2.24.0.tar.gz 234771 BLAKE2B 05111637ae26529b9345ef1f3ce8334bbcfc782e93d560749205a18e50075593573130e6ba3d33e79cd0190305ae382d44aac071c12ab67df7a8064a041220f2 SHA512 e4987b8e52be45e2fd2906525e1a4645f73b2322a6d7055f9b9c00555f4ffe05b7cda6e21cbf9f491e1e0f2b43772050017b7473b24a92cf5ca6ae6e589a15e0
EBUILD google-auth-2.23.4.ebuild 1477 BLAKE2B 9a156c2e5af7b16648efe235670c5b24df704194647c63b288bd8a6784316357148c9bbc5c9dba4d0bce746218bb70695bcd4f469df5d7b28bd8deb8930de45a SHA512 d3d91b3213fb3183f6993b520ffeaf931d069449126c20b3870493e3d0330bf7f1e8dfa47f34b69035234095bc257e7b297aa3328cdfe4b6eb87e94d0ec7b903
+EBUILD google-auth-2.24.0.ebuild 1480 BLAKE2B 79680b9d542cdafceb202bf0e1f49d7c654957aa7f186e8bd61ad53dd11ce2ab0b431d7e66ae012485ebe334161d4d3a8513f1237356500aa338d580c42bfcd2 SHA512 e7a800bf2b76574ee015da9753edcd18f4a9a7cb2953ee43f2712a7ee0d1a8164d900a790a5787af106d057fa6c9e0b8686a7077b956f31e0a71386e162476d6
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.24.0.ebuild b/dev-python/google-auth/google-auth-2.24.0.ebuild
new file mode 100644
index 000000000000..3136de42f585
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.24.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}