summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/google-auth
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest3
-rw-r--r--dev-python/google-auth/google-auth-1.0.1.ebuild50
-rw-r--r--dev-python/google-auth/metadata.xml12
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
new file mode 100644
index 000000000000..cfa985c8f25e
--- /dev/null
+++ b/dev-python/google-auth/Manifest
@@ -0,0 +1,3 @@
+DIST google-auth-1.0.1.tar.gz 133903 SHA256 dd7b6e5f3bd15c0f7cfee63a266acea40c779da0a924b475bc1812e6e10687e1 SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4 WHIRLPOOL 04560bf31278988be1c98c0d781b84cfbc48b3c1e00e772ca83d17cbf05d2db055e6a8bf732605d39cdc02a0068d898b3c5765019e2550cdc980f2da50cd222e
+EBUILD google-auth-1.0.1.ebuild 1356 SHA256 7bbf0cd4b4a7176e9fa0c7e16cc180d14a37439247f581e02d6d997cbfa58ca4 SHA512 74bf3433020cff18b04b19b1c754626c78159b8cdd7414001844f5111042ea59a8ce96193f774e57b8af653e8fa9a0dcd09612dade2061a4a086ce48e74987fc WHIRLPOOL 57a6026ece97f8efe9b24e64d74614d901ea25942e046479763087b3bf4925e4e1bf2ef9e2dcc67f2bc245b4e147783f0695a57b35e7fef755305fb2ea84da40
+MISC metadata.xml 404 SHA256 482a57654056a5e35d3fd9ebfc826653a33a074b246f6914ccf3a4fbd1d71c50 SHA512 ba3c9a09c5bc382da4c8594011872eca305111afa671adffbd3d4c04f8d772cc37d43d83385183f38311e9549c12ccff14f44f85352c49f778766134075ff32b WHIRLPOOL 4c7a8533ba6a05153c5d0f335b7aca4c95e31cf21eabc10ae2febc602972cbe32c581d535586ea1e8849334f9c0e386760f946319464e25803f8657d1804bba9
diff --git a/dev-python/google-auth/google-auth-1.0.1.ebuild b/dev-python/google-auth/google-auth-1.0.1.ebuild
new file mode 100644
index 000000000000..6a57524baac7
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.python.org/pypi/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # urllib3-1.16 raised MaxRetryError, not TransportError
+ sed -e 's:test_connection_error:_\0:' -i tests/transport/compliance.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/google-auth/metadata.xml b/dev-python/google-auth/metadata.xml
new file mode 100644
index 000000000000..9ee4c6540b0e
--- /dev/null
+++ b/dev-python/google-auth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">google-auth</remote-id>
+ <remote-id type="github">GoogleCloudPlatform/google-auth-library-python</remote-id>
+ </upstream>
+</pkgmetadata>