summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /dev-python/google-auth
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-1.4.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 48d663b5dd9a..ca8ae2324610 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-1.0.1.tar.gz 133903 BLAKE2B 0a99dcdb37a195f24077162ea8191e2eb12aac0eec8e08d06f0b17aba9c4f5ed44f19ca41c737a249611ce02b98e03474d1e995909c5755222605e004d11fb1d SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4
DIST google-auth-1.1.0.tar.gz 290602 BLAKE2B efc1ae38b29693f035ea9d19af83bd0e098dacb143192d77140ea1548a17dd051b344b6b34044f6d02e5bea631fe4026dda4ba7c1053535641f34aed08cdd48e SHA512 03b4021f5bc3c60671e1e528642af4682828e3a83a07aa9dea8a28b3f97c4020ac47f325c8a952f366d45196e6a9a78a78e1abcfc8d7f878f7b6369434a0b79f
+DIST google-auth-1.4.1.tar.gz 74272 BLAKE2B 8b9c8f59979688bc8a28d3f6c32eb06aa527b3cf9a515ceca51aa346d70622786292f5be5a4bdb2ca266b777d5d5fd41061af3afd4a2608a6673192ad643ed8f SHA512 cba174049a331c8c0ea5b82da0096641d975f59f1f2c3237c32b1730b4c9f9d12f3bfdcb6cc9b9f9c87109d509dcd423d0a4a4d98200e707052760c253f3ee45
EBUILD google-auth-1.0.1.ebuild 1352 BLAKE2B 4bc86f85500285bea12e07f09cb6c64a66d53a0bd5d6964f8eda995255eb4fa6a2e283bfb0337e9d914d771345e56c9d9997e73b8661ce3d5de1dc4ae86beafd SHA512 2f9984d4b3757109c34f32b3fc65f0ec013a4dd4c8a0e4cc969373f79c89c817c8ac4846ed1595b6fe96cb9317eaf9f4e5a869bc0845d1d57c2c7b0c83ae44a0
EBUILD google-auth-1.1.0.ebuild 1408 BLAKE2B 875a6041b147966846677fb20aabac8e6b770c029957ea6541718e65f00356acee84843d2bdcaf24870a607786281a817e112a92ebfcee5145160b3e24d6f739 SHA512 5ecb50909393bd8eed6232785b0addd3d016dded8f056e479e79438d49c9a93069c1c8706266c0fb6d5b587320af81b6cde4bfdec923d2c25efce60d8b212363
+EBUILD google-auth-1.4.1.ebuild 1227 BLAKE2B 5a471bac1110592fa6f155774bc8024886721cf819fb82f8e6367dc740b932b521cd8af2a3109bfc21aced7d5bc6d22720c113b231fa20ac6a52122dbd1a81a5 SHA512 15ee5dedf521d870ca9664fd040e671c7fb4c426d90f606980399d3dfb1d93d5921defa7b7a2b2b9bc5d941561433387f78dea4b7b4ebd2c44643dce88819914
MISC metadata.xml 404 BLAKE2B 5a7234bdd9c08a076980997db1c4fa12d2d2ee37945ccf2308e5bbd92bd01b5cbccb195a1a567f3ab82b71a1d64bf63453b4dffb2e2d7e93fdacc322f8612896 SHA512 ba3c9a09c5bc382da4c8594011872eca305111afa671adffbd3d4c04f8d772cc37d43d83385183f38311e9549c12ccff14f44f85352c49f778766134075ff32b
diff --git a/dev-python/google-auth/google-auth-1.4.1.ebuild b/dev-python/google-auth/google-auth-1.4.1.ebuild
new file mode 100644
index 000000000000..6ae35798ebd8
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}