summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/google-auth-oauthlib
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest3
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild22
-rw-r--r--dev-python/google-auth-oauthlib/metadata.xml15
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
new file mode 100644
index 000000000000..48507e4b8a15
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -0,0 +1,3 @@
+DIST google-auth-oauthlib-0.4.0.tar.gz 73664 BLAKE2B bc98af5a85b26ced36171dae4e9a498b08ddfb92cf557805a238d68fe8bc251c61be6f051db391f4c30fae0aacf139cd0cd88c3e42cdc73efeaaa36407c9496d SHA512 49760914c02b41b7252062c8cb99b133b342463aa2b66b42dd5f320320010425e6952009514cbf89a4704648113693b35db1d3aa3636fc1297a25e59635a7dd5
+EBUILD google-auth-oauthlib-0.4.0.ebuild 639 BLAKE2B e86e8c87bef47600876fcfc58d1c827bb44688da47f44e80fadfe57a9ae8480b279f87d457e4110f85ad856b90520fcde76e664c0138fa8d234909f024e84926 SHA512 31449383156850ebaf0f4761cd95f1aaf44f8023cd0196a0f3db5a07032b5329fc3d30e1e183a8c2b9036200102fac6f4b5e7dd35406c4e9a9cf88646b510418
+MISC metadata.xml 470 BLAKE2B 36db489a9e55bd13107658ae61a02e1ab39323c8eeda79b918b193471664adb2ffc2457324be492619a387d600e5dc72e08df323f17e0141793a12cdda79b89d SHA512 79b59e2f899a165f0e3a98ad3f3e809e264fb6d9b0d399329b19af3d2ab2c1628d99d9574fe4f9532646c648b6392a9cdbd9bb21739cf5d37b19c56438e185b2
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild
new file mode 100644
index 000000000000..65c76d3333d9
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/google-auth-oauthlib/metadata.xml b/dev-python/google-auth-oauthlib/metadata.xml
new file mode 100644
index 000000000000..ce124ee72b82
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>linder.gabriel@gmail.com</email>
+ <name>Gabriel Linder</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">google-auth-oauthlib</remote-id>
+ </upstream>
+</pkgmetadata>