summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
commitfc1125ea4b3373e327ba0e157daa1d7e8aee15f9 (patch)
tree44c9694d007e95c09700bf72177701759333a717 /dev-python/google-auth-oauthlib
parent5d5e56d92268c2b9b6ccc38eeaa3516ce9b1e8fd (diff)
gentoo auto-resync : 12:09:2023 - 10:40:55
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest2
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 8fa57843bd88..8c6794d3a765 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-library-python-oauthlib-1.0.0.gh.tar.gz 71294 BLAKE2B f0f085ffbec620106f5e7ead56085cee4642932a0fea1bfeec01d1f3b77a8d97aa4e6cdbc29c303abebb30e1994de86cfbb6a950bb34fc243dd312b251afc5da SHA512 74eef43e4ce8de55170c7362eaddcd796c683b3d361d52ff02db1f74b301f12e57f0acb2b52fcc5a6e661b47e3066a780915955b8d933314646483b43c8c5b68
+DIST google-auth-library-python-oauthlib-1.1.0.gh.tar.gz 71790 BLAKE2B 0d30bcb076c53052ef1a5d75276266bbbd08940953589b73c370ce66f7f20f4b47d27be8f39bfcfcd109dc7c9e7c39ddfebc65aef4953f168493ad3decdd87dd SHA512 43cd5034ed73b6509861a85abe4090f03499a98de7d88a88adf976fb33e813d31fac067ce25257b540ef71794b0d6faf7dea3c9125c0ae4468a9b2b1ba7994c4
EBUILD google-auth-oauthlib-1.0.0.ebuild 885 BLAKE2B ce605b4ae5936cdfe7f178c1d54e0b595592fdf47c4fb46eb710c3e6c400fce3a2c39edadb2258314b24061001f2e5f2e7ee56e9c0c3d50ff655903c383bf88d SHA512 a1174f6d676071a198cc6b108fb4bd91923baba044a754b77853d776a091c3917bd06afd59c3d3337f805acd2bd6bd6c52396547f8b39915c67c5b195daec7d9
+EBUILD google-auth-oauthlib-1.1.0.ebuild 885 BLAKE2B ce605b4ae5936cdfe7f178c1d54e0b595592fdf47c4fb46eb710c3e6c400fce3a2c39edadb2258314b24061001f2e5f2e7ee56e9c0c3d50ff655903c383bf88d SHA512 a1174f6d676071a198cc6b108fb4bd91923baba044a754b77853d776a091c3917bd06afd59c3d3337f805acd2bd6bd6c52396547f8b39915c67c5b195daec7d9
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild
new file mode 100644
index 000000000000..395c2d95e16a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest