summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
commit6e356edde093fb3589ab7a5859685e85c2873ab0 (patch)
tree5f17cc7bfbddda45678967fdc0a5f9f35fa9c02a /dev-python/google-auth-oauthlib
parentacb0389058b8ef612d851b1ab54fa37376c4b7f7 (diff)
gentoo auto-resync : 16:09:2022 - 17:15:17
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest2
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index bef787fdaf11..8d8bf1e8cdf6 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-library-python-oauthlib-0.5.2.gh.tar.gz 53842 BLAKE2B 7adcd9f339ec9a5528308fcc0fee1cbbe96440e1bfe5c7cc9c94808668e22801b612d291a2419333888194c3224838ac40f9d0656381825bd660067470f58910 SHA512 eaf296a0e0504e8249637a8db7531c10b120f28abeeab3e1fe8f366b4279c396509188e83f8a0ec56be85063430ceb691d6d926cee33d4f166bbcc4425e538db
+DIST google-auth-library-python-oauthlib-0.5.3.gh.tar.gz 69613 BLAKE2B 74338894f35fd1cd8802ea56952561ce0e801fecb2f994b71caf3c6b62a22e8b85f8a5b40f5571b05225a565b373865377d321625aeea2dafcc0cafb89da1492 SHA512 76c855e9becd57d3cb3bb0b203ad77ef17dc04e8be8b96d17a9c1f29474a8b180edb725e835d0552c5eddbb387cc463e88b076dd6d11635e6d45798224f09188
EBUILD google-auth-oauthlib-0.5.2.ebuild 876 BLAKE2B 97153977e671f5a8e24315290ce154c41bf478add7b9103141df177381631adfb7a4e7001888a8362ee09f11213c1d461b480436d649d59f9f089ff95c1a25db SHA512 eb04ca36f3939bf0f76b0118ba8c629e39b9bec056c5afd322a2d73b3d655d9af6c2786db17b16f0f7010e0e9f150c14f11cc56671b43e3f876e4477f8ed48b9
+EBUILD google-auth-oauthlib-0.5.3.ebuild 876 BLAKE2B 97153977e671f5a8e24315290ce154c41bf478add7b9103141df177381631adfb7a4e7001888a8362ee09f11213c1d461b480436d649d59f9f089ff95c1a25db SHA512 eb04ca36f3939bf0f76b0118ba8c629e39b9bec056c5afd322a2d73b3d655d9af6c2786db17b16f0f7010e0e9f150c14f11cc56671b43e3f876e4477f8ed48b9
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild
new file mode 100644
index 000000000000..9aa755ca297b
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest