summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
commit2237cda0c6b012952e02ec1314e1f48eddf4dab7 (patch)
tree0a7ab76265dc441f4b3436f07d019007e6a13237 /dev-python/google-auth-oauthlib
parent6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (diff)
gentoo auto-resync : 08:01:2023 - 18:16:34
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 5c353144b92a..4ed27daac2e5 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -2,4 +2,5 @@ DIST google-auth-library-python-oauthlib-0.7.1.gh.tar.gz 70325 BLAKE2B 969b6de0b
DIST google-auth-library-python-oauthlib-0.8.0.gh.tar.gz 71774 BLAKE2B 100aa01586f5df18453713610f3ed954a196e3d0c8d4dc15b8a67335951cbc2eaa15e3fa4bf7c7ba161418550bb7cfc68630fca0efe697a9c65ccbd7e0ce05d9 SHA512 3090d9b3ad25df6e8151e49a0cd96e7226aac2cecbbf289ccbc8cf4704ec86d882c11546b26f3a2ba9b047c19408f0cb939b9caf489aa935f49f8990ab7bfa55
EBUILD google-auth-oauthlib-0.7.1.ebuild 877 BLAKE2B e01c55a12bf9897a5df0d230a0e9d9266b3de3a1c2c6b1a5623bc94f46c5ab5435a6e26acd88fd5bb952bfb7a68b08d7fd56948511852fd4b0587519014a29b6 SHA512 043abcce2d9143bd5c029b9eb7ebeb006bcc4153f7d2adffccbcd2d381325432d76cfd6d553c4dc0f25a760944d828ce3b10b2ed80713df6dd256f5dbcbe3542
EBUILD google-auth-oauthlib-0.8.0-r1.ebuild 877 BLAKE2B 6517855ba3910fff7fded1e9983fe7ae41007011326527cc24f6afcb88ec6eabcfc027adfd482a03d172647af09d06a904c27a90502c86bb1465777eaa8474ce SHA512 a0e2e64b63e27a8afe3cbdca9e3b854604f75a5498274c07732b753b891215957ad8b66376bab3ea295d858459ee694c74e9231501bc1869854601836cf67a87
+EBUILD google-auth-oauthlib-0.8.0-r2.ebuild 878 BLAKE2B 7516cef25ce2af84ea44bbf16a87af1399f7da90296c0549f7339b58a50147ca6a3a4bb7dfd11e9cf115872d6ad6b44c08baa76544e26a7f1cf348a9a82a0e5f SHA512 e33125b63875d02a5267017ddde5ca894901c6ffefed2c821237e0ce3b5cadf5dee0db3d9cd871d3398b707331a4d40fdec931fa8ab47d56afb3916640cc4732
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..428011855aa4
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest