summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/google-auth-oauthlib
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest4
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild4
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild22
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 48507e4b8a15..5076bd9af20d 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-oauthlib-0.4.0.tar.gz 73664 BLAKE2B bc98af5a85b26ced36171dae4e9a498b08ddfb92cf557805a238d68fe8bc251c61be6f051db391f4c30fae0aacf139cd0cd88c3e42cdc73efeaaa36407c9496d SHA512 49760914c02b41b7252062c8cb99b133b342463aa2b66b42dd5f320320010425e6952009514cbf89a4704648113693b35db1d3aa3636fc1297a25e59635a7dd5
-EBUILD google-auth-oauthlib-0.4.0.ebuild 639 BLAKE2B e86e8c87bef47600876fcfc58d1c827bb44688da47f44e80fadfe57a9ae8480b279f87d457e4110f85ad856b90520fcde76e664c0138fa8d234909f024e84926 SHA512 31449383156850ebaf0f4761cd95f1aaf44f8023cd0196a0f3db5a07032b5329fc3d30e1e183a8c2b9036200102fac6f4b5e7dd35406c4e9a9cf88646b510418
+DIST google-auth-oauthlib-0.4.1.tar.gz 18687 BLAKE2B 1c9028f6b4c306bbee51fba5b55950d129d56ff5154645a166998c0c720b125202731f1cfed60837b8103d56fcdeeb818e39491b243a8d761969f73d9f88f67b SHA512 123707139353db8e05c81138af834e35007d323f0e19ae79088ad5ca4be86dda6c0df91e2f7794711475227a60312fab9101c91b49817bf8b84866ea6374c943
+EBUILD google-auth-oauthlib-0.4.0.ebuild 635 BLAKE2B 4a2c3a2f907c7c76d2a82db975ef29449a009b75b991d3c64641a0b7050258716dfe82d734b0169a323f1f733ff19b1069eb34fd3aa41a8147cb983fb9ddf49b SHA512 8ea139f9aee2435973200ddfa0c150e3d943be731288116194d9f177d31f46ddfa6a62aa7b5a29ea3d98ad7dcf4ce88b2319820957cc861e81cfdbb6cc791d9f
+EBUILD google-auth-oauthlib-0.4.1.ebuild 639 BLAKE2B fc64473c6282e6249f2bc4af62f8d912bf086bf6f8bbbdb1c877bd1fbc02505449e8ba37cd1829d1f240c07924efc07263736c57d1130c98b632eeadbaff46c8 SHA512 2f71d9cb4c50220ec03664a77efb774622bd305851d4992e71f08caddda8a6f32a297082d03a5e90fe6e205461a51aab67465d6fabc6b43585a1e9d20fe3b61f
MISC metadata.xml 470 BLAKE2B 36db489a9e55bd13107658ae61a02e1ab39323c8eeda79b918b193471664adb2ffc2457324be492619a387d600e5dc72e08df323f17e0141793a12cdda79b89d SHA512 79b59e2f899a165f0e3a98ad3f3e809e264fb6d9b0d399329b19af3d2ab2c1628d99d9574fe4f9532646c648b6392a9cdbd9bb21739cf5d37b19c56438e185b2
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild
index 65c76d3333d9..1d783fffbfd6 100644
--- a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_6 )
inherit distutils-r1
DESCRIPTION="Google Authentication Library"
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
new file mode 100644
index 000000000000..33d8c12b6cec
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"