summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 18:59:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 18:59:30 +0000
commit1e1e7636b59380beebd325e8d256875e4f824230 (patch)
treecac3706b236cea47f66f8d45afc943890cd4375e /dev-python/google-auth-oauthlib
parent5cbf14acf23c82626389931f64cfe3ef12a1c29f (diff)
gentoo auto-resync : 08:01:2024 - 18:59:30
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest3
-rw-r--r--dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch25
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild (renamed from dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild)7
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index a8983c6b8e65..6fc3e956c968 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,4 @@
+AUX google-auth-oauthlib-1.2.0-setup-exclude.patch 863 BLAKE2B 9ac621f5693a52627bdcda558a6b260ddb4c48f98d518f69285923ddbf74179a55fe825e984363d69f5d561b6fe886721f442b7b1a1defa92330e83efc9257cc SHA512 f5f1c138c94855f2a93ac61e5379d8dea971db6d245b99daab4325a2c8604123c2a8895d46f5f31618143f5920cf2ca175955ec6249287470b787f46cad31bbb
DIST google-auth-library-python-oauthlib-1.2.0.gh.tar.gz 72990 BLAKE2B 28b828a2a6b4de9deda8eef08f6780cd6f8d3a4df2f63d31c76b72afca12233d79edae46300d773301f7e9d6374e9dbcb5a89b59049a5c01ea5a84ac92285b82 SHA512 2f77d35f76ec12bfdc72dafe9cb33d23c2713985140930766a75377231dc94c32ffa84161251b23244dcf76fe71384421a5d6d8ae11a84b3876d35b5ba393f5a
-EBUILD google-auth-oauthlib-1.2.0.ebuild 885 BLAKE2B ce605b4ae5936cdfe7f178c1d54e0b595592fdf47c4fb46eb710c3e6c400fce3a2c39edadb2258314b24061001f2e5f2e7ee56e9c0c3d50ff655903c383bf88d SHA512 a1174f6d676071a198cc6b108fb4bd91923baba044a754b77853d776a091c3917bd06afd59c3d3337f805acd2bd6bd6c52396547f8b39915c67c5b195daec7d9
+EBUILD google-auth-oauthlib-1.2.0-r1.ebuild 1016 BLAKE2B 3f775e49f6605b3437456cfe3f8b412f278dde391759e7e9ef848979dc0b5e82812897117687a8755a813a33aee24f73eca1e87349c1a4d985d4cb7b3af5e0aa SHA512 d8c1906e90b2994352b260a6602c68ab32000970a75ec8e83b253610d41e3b9cadfa9b3010cd8880f4005b561a5ff8f4b1ab583da6ae5a9f644d1bb93f53222e
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
new file mode 100644
index 000000000000..61349d1cce43
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
@@ -0,0 +1,25 @@
+From dffa74bf7cb25d4e7759b4d0cded68eabfaaf33b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 8 Jan 2024 15:58:00 +0100
+Subject: [PATCH] fix: do not include docs/conf.py & scripts in wheel
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index ea9796a..430db0c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -37,7 +37,7 @@ setup(
+ description="Google Authentication Library",
+ long_description=long_description,
+ url="https://github.com/GoogleCloudPlatform/google-auth-library-python-oauthlib",
+- packages=find_namespace_packages(exclude=("tests*",)),
++ packages=find_namespace_packages(exclude=("docs*", "scripts*", "tests*",)),
+ install_requires=DEPENDENCIES,
+ extras_require={"tool": TOOL_DEPENDENCIES},
+ entry_points={
+--
+2.43.0
+
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
index 395c2d95e16a..04dbde55c9ab 100644
--- a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -37,3 +37,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/googleapis/google-auth-library-python-oauthlib/pull/328
+ "${FILESDIR}/${P}-setup-exclude.patch"
+)