summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-python/google-auth-httplib2
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest2
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index b95f92890973..6e6c9578172b 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-httplib2-0.0.2.tar.gz 10830 BLAKE2B 7f2092d83c318510b9140791681a58bd3e436f3b5966c8dc53aa5b041e50fdc4f93c276810a0e6ca20b14a919eb37588ae1d027b5eba74f79f44a6809909dd4f SHA512 ec111fdad930bfe3f8f97df70a8bef955920ab2cb0c383d7888ff444f19e5c176dd5aabe10f9a870c86035791a2b27e3e8e1276360626ff5e430db823da5efb0
+DIST google-auth-httplib2-0.0.3.tar.gz 10914 BLAKE2B 20473182a5bd4633d1ae16101d81520ddf182706d478c066e533a2eac3e28fccf2bbaf733eeb4f7ea14d658fe29b9b0c656307bb555aabd2d1a21585e3e3d3ba SHA512 dc39626961dfc67ee56d1c74b4e37e6c6a81ec3c8ddcc24007535acc6a973f2cba5e65a9ece323f53d4dcb4f7bca948d65bde4ab55b2c002432d020cba9d914e
EBUILD google-auth-httplib2-0.0.2.ebuild 1156 BLAKE2B d36bc321fd39ebcd733cab2332265a6993ef7a1ec067565111d42515102dcd4e2f03b7f71a0a15a4ed1d7b769d79a18426d32e8a053b9d87eacff51477713128 SHA512 1c21b4c86d9f93b31d2b5e88f685f754635cf3dea2bb7c0519c532a12cf751167712947bc4de1d4726c50e2250c1902f1d08baf8201f0bb7bf2c19d85d4cb525
+EBUILD google-auth-httplib2-0.0.3.ebuild 1162 BLAKE2B 1d8327a85ddf7ddf2599f89854d7d531dece4e52dc56bd5542005e3cd1a3af1068a829e5cd629d40aaaae8619f54bacf4f52768cb6f84846ba4f206392d4be21 SHA512 aa595615b2f84a39a661716465cb774b584afb5dad0251bc0d77288281828a1a32f7a47ff2452fc34553c11361f683e272f964cbc78a19c7a20a018f2d2af10f
MISC metadata.xml 422 BLAKE2B 4aa4a1542a90ed8ebc399dff1824e77e9f695104e4e59317af95e21719d993ceea8c5ed512d15cc2d9d4085bdd1afcc70a58e2f0d7ce673508e2cb6f52d3664b SHA512 bba9deccadfaf0b663a2f6239633f20ee02838d98cfa25e4d8c399e5635c4cd0b811dbf821f18edf98b328a56a37146bc316aceed6b5b057ef5fd2cd151bbaa2
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild
new file mode 100644
index 000000000000..1b43fb88d253
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+EGIT_COMMIT="e7cd722281d1d897fa9ae6e3b6b78ae142778e6e"
+MY_PN="google-auth-library-python-httplib2"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/ https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+# PyPi tarball is missing unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}