summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
commit2237cda0c6b012952e02ec1314e1f48eddf4dab7 (patch)
tree0a7ab76265dc441f4b3436f07d019007e6a13237 /dev-python/google-auth-httplib2
parent6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (diff)
gentoo auto-resync : 08:01:2023 - 18:16:34
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest2
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 8b643388c081..69cd287288df 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1,3 +1,5 @@
+DIST google-auth-library-python-httplib2-0.1.0.gh.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
DIST google-auth-library-python-httplib2-0.1.0.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
EBUILD google-auth-httplib2-0.1.0-r1.ebuild 904 BLAKE2B 9b79ac338c6dda59973e0f44c2be00bb2272bc0cdaa20af1130728018fddccc728f1eab1baa25bcce7fffc0d81fdd494b3c3fbffc3ebf8391f1e67602a60d67b SHA512 33d1f59785aa5a36b47117f3778f83ba7cdac47030816e0dc9680127d07cfefd2f9b8cd008db0fd9d18a1f2b9ba72c89e897aa816fb5b918eb75f6af3e5cc286
+EBUILD google-auth-httplib2-0.1.0-r2.ebuild 913 BLAKE2B 39050d32ea17f753728696c56c3c641045459e6176dad0b6dd387a315e43b442152fb42ae8b2f46b889830c32d641a8d688b23eac2133ac3f96ceee5a6263125 SHA512 fb7dc06d2a66d82fcd63334656bc43212bd5866366a2d3f464f3ee2ddc900444d6b0b8e3026edd4ae52d7abe782033ef76f057c30e48f4d8b58a13630b657ddf
MISC metadata.xml 539 BLAKE2B eefbb5db5d696a71dbc67ace7becb705ac048632e0434e516aa2fbc6e963ea86713beb4b1a2109e29e16b9844c2bf62ebbec527379c13f0f390d2cdae23e77e8 SHA512 03b6328fffb6014d3cccac0687e2b652b5522f345c125ec69c62dc020a8a6baaef444dbdfadef6dd8119d1a19449d57893e207ae4f2ac35d5592c23cad931c2c
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r2.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..74cd7713007c
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P="google-auth-library-python-httplib2-${PV}"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-httplib2/
+ https://github.com/googleapis/google-auth-library-python-httplib2/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-httplib2/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest