summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
commit0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (patch)
tree93ef9828fae35063d273f386b2fa4a7130add56b /dev-python/google-auth-httplib2
parent22b4e2ee9c8011b75d7c030d6129a7487494aeba (diff)
gentoo auto-resync : 13:12:2023 - 11:40:30
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest2
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.2.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 89ccb3056609..10b6d84598be 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-library-python-httplib2-0.1.1.gh.tar.gz 43818 BLAKE2B 629e370d3509c8d7b47b9192f3192b013be184df8e245cd73941d233645344f019b760e92ed2119c3b0c1e6b5db0ebf74f52f7c56bd34f8c6f61cbb41311814d SHA512 2272c7019b0f47344c45d45d88f9a9de5be410764dda5ea22271a8661856abf3b3c5d92937aa126f51c385dc91b5c79578fbb81570d7f4b636a3229ad0a95403
+DIST google-auth-library-python-httplib2-0.2.0.gh.tar.gz 45105 BLAKE2B 096939bcf0b3d47fc57cbb249d0c80fc13c29d8fbde1a0ac7f490e0d1d817e550c74ac37ed460d9fb122c804cf97e9a796b2ef2191752bcfaf7c233fa7d38176 SHA512 d6bf677826b785775f126ca3f7962ca0684b33b424b0d3be15cc68c536d78ad61002166c90c959fd51736bc2f7d82b0b29778a7eae5aef6268953f07e64157d7
EBUILD google-auth-httplib2-0.1.1.ebuild 910 BLAKE2B 21954d6fe46ff1612c99567c064ecf0f4836d57f11fffdcdd7ec755a3a80dc53435165413b99647c21f8a43c8375955e25f56a4fac228d020e355b1633c3aad9 SHA512 805d343a82389c6d3214160e3590a8f733e040c2c6ebff6a29b27498b91fd0685a929709e733185604a8a64ca6af3e1c4830b0d36910c76762e0c432a6ae2f85
+EBUILD google-auth-httplib2-0.2.0.ebuild 877 BLAKE2B 971dafca97292234c00ea06b7d4358809476a079651e70b71b49702692a556ce3f55ef5af03206317e79804fde7729cd7ea56b42656eed76df68ffdcb410b9d5 SHA512 42891f2eb527793fcc446962cf2e1dceef045870270ab5278b240fc3f91a9d3109b4863713de4f37d2d27c1562fa36bfed99ee665ff1da10d6082eb3b51305ac
MISC metadata.xml 539 BLAKE2B eefbb5db5d696a71dbc67ace7becb705ac048632e0434e516aa2fbc6e963ea86713beb4b1a2109e29e16b9844c2bf62ebbec527379c13f0f390d2cdae23e77e8 SHA512 03b6328fffb6014d3cccac0687e2b652b5522f345c125ec69c62dc020a8a6baaef444dbdfadef6dd8119d1a19449d57893e207ae4f2ac35d5592c23cad931c2c
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.2.0.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.2.0.ebuild
new file mode 100644
index 000000000000..b782b2e96619
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P="google-auth-library-python-httplib2-${PV}"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-httplib2/
+ https://github.com/googleapis/google-auth-library-python-httplib2/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-httplib2/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest