summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
commit95b557bc48bb734c288bac87dcfe98b8ae3d1cdb (patch)
treec5ffde10d5eed804daa50794c905d6b228af7177 /dev-python/google-api-python-client
parent3b34ca9eec2676e6fe530f34e463f52308a11441 (diff)
gentoo auto-resync : 18:01:2023 - 11:56:49
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.73.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 7630c439a10e..dcddecf88b15 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.71.0.gh.tar.gz 37887241 BLAKE2B 5b0e8f39a4935f6e64e1846b7457e2fef62f91d8b62debd277dd49fe28242ffa6d1f8bf8962b56860448aa0edd8fe23d102062809995b212b775c760d20b403c SHA512 a13e31226991a77f900e87f72232d6722dc34d3b7a0134fed3039a5439d207ee26a3f9caa8b4cc5319acc864e11f07e080c0cea25ff29ab1a775b49278582c83
DIST google-api-python-client-2.72.0.gh.tar.gz 37897701 BLAKE2B fff35a2103f7d3a58e790cb6b385a881c572c2272bc078531912f69d26ac16433513d97ac724f70e47b250dbaac95a78e1df04c2ea7a030325f6ead9de42646d SHA512 1bb625fc6d9aeacebf0b03a77709367d9b29e33f171b5c708a90141e697d29fcf8689d3d6a71f21a50e976feaef5fc2aec9451525a2aa00867639fdfc401c262
+DIST google-api-python-client-2.73.0.gh.tar.gz 37984359 BLAKE2B e82fe357010c06601a58cac4e0e2c72c8f1d9e7ae5663248b5fa5ab4d0d3cbebc597fcce560cd157e363fd1edf9a1fed76570a43f5cf64ef45a7fb84902a5918 SHA512 6af39b7ce526d91de2c7d01c660ca951a6775453478ea8fe50e3a8def30114fdb90fa5b7490fb9b02c1ba4d38bde55e4b4c05ad61ba3713f9c7341cdfdbaf619
EBUILD google-api-python-client-2.71.0-r1.ebuild 1437 BLAKE2B fd9012abcfd1cfb551de456691cc09dee7694b5d1a256a182de804a775c183e64950e999730d51225dae6902d96cc5c0aae484ecd20fd8673f329cccae1ef4c6 SHA512 47707bcd49dd89e2ebeabc44c816e47fe34e239ff374992b559ddb8d85c93175714e74ee8cd200a4d3e6190e54b31e23c55b07073de3c41b76ea884b67a9831c
EBUILD google-api-python-client-2.72.0.ebuild 1395 BLAKE2B 6a666ce06c23f1a334d4287d52887adf1b5adf1aac257387583dd14fc4f597378b0cc76f19905c1300080963276ffcdc3cbd0c74b7c2efe220a86417a38a10bb SHA512 503fad15193434626ba75dd5ad18f0e144d74875a6e914d231b38ae4f295f8e6da8d9ac94d9d3839c9805014583a464f0230797e62b76ca4e8b85234c5b7fb3c
+EBUILD google-api-python-client-2.73.0.ebuild 1395 BLAKE2B 6a666ce06c23f1a334d4287d52887adf1b5adf1aac257387583dd14fc4f597378b0cc76f19905c1300080963276ffcdc3cbd0c74b7c2efe220a86417a38a10bb SHA512 503fad15193434626ba75dd5ad18f0e144d74875a6e914d231b38ae4f295f8e6da8d9ac94d9d3839c9805014583a464f0230797e62b76ca4e8b85234c5b7fb3c
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.73.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.73.0.ebuild
new file mode 100644
index 000000000000..7f5368fd7fde
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.73.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}